Search found 40 matches

by Tomservo
Fri Jun 26, 2009 12:02 pm
Forum: Solaris
Topic: Panic with Nevada 114 & intel hd audio (975x chipset)
Replies: 3
Views: 19023

Same happens here with a selfcompiled old ass 4.1 build, oss_cmi8788 and snv_117.
by Tomservo
Sun May 31, 2009 12:05 pm
Forum: Solaris
Topic: Solaris 10 u7 /dev/oss/oss_ich0/pcm0: Device busy
Replies: 5
Views: 24608

Now nothing works. Every OSS application reports a problem with the device. osstest works exactly one, afterwards the device's busy.
by Tomservo
Sat May 30, 2009 8:58 pm
Forum: Solaris
Topic: Solaris 10 u7 /dev/oss/oss_ich0/pcm0: Device busy
Replies: 5
Views: 24608

Actually, do make it work, I had to do it that way:

- Installing the package.
- Reboot.
- ossdevlinks -vr
- Reboot.
- ossdevlinks -vr again.

Haven't rebooted anymore since then, hope it doesn't start again like with an earlier build I've used, where I had to ossdevlinks every reboot.
by Tomservo
Sat May 30, 2009 8:30 pm
Forum: Announcements
Topic: OSS 4.1 build 1052
Replies: 6
Views: 40672

What does support for Boomer mean? API level, or could you run individual drivers under Boomer?
by Tomservo
Fri Jun 27, 2008 2:45 pm
Forum: Solaris
Topic: OSS issue with Open Solaris 2008.05
Replies: 5
Views: 21025

There's no sudo in Solaris. It's pfexec.
by Tomservo
Fri Jun 20, 2008 12:37 pm
Forum: Solaris
Topic: sadasupport and vmix broken with cmi8788 driver?
Replies: 3
Views: 14940

Hg changeset v4.1-080619 (i.e. from yesterday) fixed sadasupport for me. \o/
by Tomservo
Thu Jun 05, 2008 12:54 pm
Forum: Solaris
Topic: sadasupport and vmix broken with cmi8788 driver?
Replies: 3
Views: 14940

The latest tarball of 4.1 made vmix work, sadasupport still whines about this:

May 24 21:48:30 hyperborea sadasupport: [ID 998106 kern.warning] WARNING: ldi_ioctl(SNDCTL_AUDIOINFO) failed, err=22
by Tomservo
Sun May 25, 2008 12:12 pm
Forum: Solaris
Topic: sadasupport and vmix broken with cmi8788 driver?
Replies: 3
Views: 14940

sadasupport and vmix broken with cmi8788 driver?

I can't get either sadasupport nor vmix to work with the cmi8788 driver. OSS 1015. With sadasupport, it attaches fine, but when trying to play something back with SADA, the syslog starts filling with this: May 24 21:48:30 hyperborea sadasupport: [ID 998106 kern.warning] WARNING: ldi_ioctl(SNDCTL...
by Tomservo
Thu Apr 10, 2008 1:41 pm
Forum: Solaris
Topic: Asus Xonar XD, the first attempt!
Replies: 10
Views: 27117

Yay, I've output on the front. Since it took me three days of poking in the dark (i.e. lack of docs), I'll continue on it this weekend only. Getting the other DAC up should go quickly now. As far as the other Xonar's go, that'll probably end in a theoretical exercise.
by Tomservo
Tue Apr 08, 2008 12:13 pm
Forum: Solaris
Topic: Asus Xonar XD, the first attempt!
Replies: 10
Views: 27117

We've sent a message to the CMedia guys about the driver. Lets see if they have new info about the Xonar device. Did you try running osstest and plugging a pair of speakers in each of the output jacks? Tried all the different outputs, even the SPDIF input for fun. Nothing. I'm currently trying to m...
by Tomservo
Sun Apr 06, 2008 5:31 pm
Forum: Solaris
Topic: Asus Xonar XD, the first attempt!
Replies: 10
Views: 27117

Newer Solaris build (OpenSolaris Developer Preview 2) and the driver now works. There's actually no output at all because it's the wrong DAC, I'm poking with a stick at it, but to no avail yet. I'm taking clues from the ALSA driver, but as of yet, I haven't managed to make it output sound.
by Tomservo
Fri Apr 04, 2008 5:43 pm
Forum: Solaris
Topic: Asus Xonar XD, the first attempt!
Replies: 10
Views: 27117

Turns out the CMI8788 on the Xonar is not so much the same. The Linux ALSA folks have a seperate driver for the Xonar, based on the existing CMI8788 one. That's kind of strange, because the same time, you can drive it with the regular CMI8788 driver in Windows.
by Tomservo
Fri Apr 04, 2008 1:37 pm
Forum: Solaris
Topic: Asus Xonar XD, the first attempt!
Replies: 10
Views: 27117

Asus Xonar XD, the first attempt!

Just so that one thing's clear, the device works fine in Windows Vista. So it's not faulty. Ok, here's the deal: That card is simply a CMI8788 behind a PCIe bridge (of type PEX8112). OSS finds the card and attaches the driver, but that's it. Operating system is Solaris Nevada snv_76. Next upgrade ha...
by Tomservo
Fri Mar 28, 2008 11:33 pm
Forum: Solaris
Topic: Does sblive hardware mixing even work under Solaris?
Replies: 1
Views: 9097

Nevermind. It's simply sblive.conf being ignored. Well, that's great.

http://www.4front-tech.com/forum/viewtopic.php?p=6478
by Tomservo
Fri Mar 28, 2008 11:11 pm
Forum: Solaris
Topic: Does sblive hardware mixing even work under Solaris?
Replies: 1
Views: 9097

Does sblive hardware mixing even work under Solaris?

Does the hardware mixing on EMU10Kx cards on the Solaris version of the driver even work? I've sblive_devices set to 16 and vmix not loaded. Still, I can't play more than one audio stream, any other application reports the device busy. --edit: ossinfo -a -v Audio devices SB Audigy2 main /dev/oss/sbl...

Go to advanced search