Search found 25 matches

by roman_austria
Wed May 13, 2009 10:02 pm
Forum: Solaris
Topic: Driver fails to attach ...
Replies: 8
Views: 32833

Re: Driver fails to attach ...

Hi,

it has been a long time since the last install, but I encounter still the same error. By now I am using b112. And the error is again: Failed to attach the driver.

This time I downloaded the package and did not built it myself. OSS version 4.1 Build 1052.

-Roman
by roman_austria
Fri Dec 12, 2008 9:59 am
Forum: Solaris
Topic: Driver fails to attach ...
Replies: 8
Views: 32833

I assume that the gnome-volume-control in Solaris is similar to Linux in that it uses gstreamer. If this is the case check whether with gstreamer plugins bad installed that a libgstoss 4 audio library file exists. If not then you may need to update to a newer version of gstreamer. You are right. So...
by roman_austria
Wed Dec 10, 2008 9:39 pm
Forum: Solaris
Topic: Driver fails to attach ...
Replies: 8
Views: 32833

Re: Driver fails to attach ...

Hi Dev, after update_drv to add another alias to oss_hdaudio update_drv -a -i '"pci30b0,103c"' ossxmix showed up which didn't work before. osstest worked with errors. The only thing left is that GNOME doesn't recognize the mixer device. Could you please assist me to get that work too? Gree...
by roman_austria
Tue Dec 09, 2008 8:10 pm
Forum: Solaris
Topic: Driver fails to attach ...
Replies: 8
Views: 32833

Re: Driver fails to attach ...

Hi, If you have OSS b1016 then you need to remove that and reboot and then install build 1050. The driver names and bindings have changed and that is the reason you need to pkgrm oss and reboot before installing 1050. The other thing you can try is reboot and then run ossdetect. regards Dev Hi Dev,...
by roman_austria
Sun Dec 07, 2008 10:10 pm
Forum: Solaris
Topic: Driver fails to attach ...
Replies: 8
Views: 32833

Driver fails to attach ...

Hi, on SXCE b103 I have the problem that OSS cannot install properly. The OSS version is 'oss-solaris-v4.1-1050-i386.pkg'. It is built from the current mercurial repository. Before b101 OSS always worked when I built it with the sources from the mercurial repository. OSS was my last resort, because ...
by roman_austria
Thu Jun 19, 2008 10:07 am
Forum: Solaris
Topic: Compile errors: Cannot find <sys/audio.h>
Replies: 20
Views: 45416

Thank you for your hint. SUNWGtku installs legacy versions of GTK. I can't follow the package politics of OpenSolaris 2008.05 ... I don't know why it doesn't load on reboot. Hopefully someone else does... One possible reason could be that for OpenSolaris 2008.05 a different approach for installation...
by roman_austria
Thu Jun 19, 2008 8:08 am
Forum: Solaris
Topic: Compile errors: Cannot find <sys/audio.h>
Replies: 20
Views: 45416

So for now I have installed SUNWGtk which also included SUNWGlib. So I got the following compile error: "gtkvu.c", line 8: cannot find include file: "gtk/gtkmain.h" "gtkmain.h" is installed under /usr/include/gtk-2.0/gtk/gtkmain.h Either the package is not installed cor...
by roman_austria
Thu Jun 19, 2008 7:04 am
Forum: Solaris
Topic: Compile errors: Cannot find <sys/audio.h>
Replies: 20
Views: 45416

Hey, cool, enjoy OSS. :) -Ionic Oh my gosh, the journey is not ended ... "ossxmix" is missing. I think due to missing GTK stuff. "osstest" worked right after installation, but after reboot it states: -bash-3.2$ osstest Sound subsystem and version: OSS 4.1 (b 080607/200806181...
by roman_austria
Wed Jun 18, 2008 2:58 pm
Forum: Solaris
Topic: Compile errors: Cannot find <sys/audio.h>
Replies: 20
Views: 45416

Hi, could you please install CSWgawk? I had a quick look at the Blastwave repo and found it there with this name. I hope that's working. :) -Ionic Don't get me wrong, but IMHO I avoid blastwave when possible. As the name implies a blast of packages are to be installed, and that is not my intention....
by roman_austria
Wed Jun 18, 2008 1:53 pm
Forum: Solaris
Topic: Compile errors: Cannot find <sys/audio.h>
Replies: 20
Views: 45416

You're better off installing SFWgawk. (gawk is used for man pages since txt2man uses a GNU extension. Actually the install can avoid it and use a lower-quality method, not sure why it doesn't). So it's me again ... Sorry, SFWgawk couldn't be found in the repository. Where could I find that package?...
by roman_austria
Wed Jun 18, 2008 1:33 pm
Forum: Solaris
Topic: Compile errors: Cannot find <sys/audio.h>
Replies: 20
Views: 45416

You need SUNWusbu package to be installed for that file. Thank you for this hint. For now the build seemed to run smoothly, but another packege might missing. oss-gate/setup/txt2man: line 172: gawk: not found I have an awk installed found in /usr/bin. So if I could do a symbolic link to gawk to get...
by roman_austria
Wed Jun 18, 2008 1:06 pm
Forum: Solaris
Topic: Compile errors: Cannot find <sys/audio.h>
Replies: 20
Views: 45416

Ionic wrote:Hi,

I assumed you would fetch the patch the same day. :P

http://oss.pastebin.com/mf5bbd8a here it is again.

Yeah, I mean the mercurial repository. :)

-Ionic


So for now I have the problem that configure states:

Cannot locate "sys/usb/usbai.h" (<>, doesn't work)

Roman
by roman_austria
Wed Jun 18, 2008 12:29 pm
Forum: Solaris
Topic: Compile errors: Cannot find <sys/audio.h>
Replies: 20
Views: 45416

Hello roman, could you please try the following patch and report back, please? (against current HG): http://oss.pastebin.com/d316e8525 (seems like the Forum is not allowing pasting code - it replaced some necessary things...) -Ionic Hi Ionic, sorry for the delay. If you mean the mercurial repositor...
by roman_austria
Mon Jun 16, 2008 2:22 pm
Forum: Solaris
Topic: Compile errors: Cannot find <sys/audio.h>
Replies: 20
Views: 45416

I missed the SUNWaudh package. But the compilation
still not works. A lot of undefined symbol errors occurred.
Like:

Code: Select all

"udi.c", line 627: undefined symbol: USB_SUCCESS


Roman.
by roman_austria
Mon Jun 16, 2008 8:56 am
Forum: Solaris
Topic: Compile errors: Cannot find <sys/audio.h>
Replies: 20
Views: 45416

Hi, thank you for your answers. What I am using: OpenSolaris 2008.05 Which compilers do I have installed: SunStudio 12 (over the packaging system) To Ionic: I am aware of how to access the path, but thank you. I'll check if I have installed either SUNWaudh, or SUNWhea respecitvely. Roman.

Go to advanced search