Search found 78 matches

by adamk
Sat Nov 05, 2011 11:30 pm
Forum: Linux
Topic: mic/line-in passthrough with oss_hdaudio
Replies: 2
Views: 6024

Re: mic/line-in passthrough with oss_hdaudio

I get a few extra mixer controls but the only "misc" control is simply "misc" still: [adamk@sorrow ~]$ ossmix Selected mixer 0/High Definition Audio STAC9200 Known controls are: jack.internal.mode <spdifout|select> (currently select) jack.fp-black.mode1 <select|input> (currently ...
by adamk
Mon Oct 24, 2011 9:48 pm
Forum: Linux
Topic: mic/line-in passthrough with oss_hdaudio
Replies: 2
Views: 6024

mic/line-in passthrough with oss_hdaudio

Version info: OSS 4.2 (b 2005/201109062301) (0x00040100) OSS_HG Hg revision: changeset: 937:998ceefba722 summary: Added tag v4.2-2005 for changeset 11205524a8ce, tag: tip summary: Added tag v4.2-2005 for changeset 11205524a8ce, date: Fri Aug 12 07:59:07 2011 +0300, summary: Added tag v4.2-2005 for ...
by adamk
Thu Sep 29, 2011 11:40 am
Forum: Linux
Topic: Streaming audio and video via vlc with OSSv4
Replies: 2
Views: 9306

Re: Streaming audio and video via vlc with OSSv4

So no thoughts about this VLC problem?

Adam
by adamk
Sun Sep 04, 2011 4:32 pm
Forum: Linux
Topic: Streaming audio and video via vlc with OSSv4
Replies: 2
Views: 9306

Streaming audio and video via vlc with OSSv4

I've tried on two separate machines, one with oss_em10k1x and one with snd_hdaudio, so it doesn't seem to be driver/card specific, but rather an issue with OSSv4, in general, and VLC. vlc starts up, claims to open /dev/dsp, but it doesn't stream any audio. If I connect to the stream from another mac...
by adamk
Wed Nov 03, 2010 12:41 am
Forum: Linux
Topic: vmware on oss_hdaudio
Replies: 5
Views: 7772

Re: vmware on oss_hdaudio

For what it's worth, this is in the windows XP vmx file:

Code: Select all

sound.present = "TRUE"
sound.fileName = "/dev/dsp"
sound.autodetect = "FALSE"
by adamk
Sun Oct 31, 2010 2:34 pm
Forum: Linux
Topic: vmware on oss_hdaudio
Replies: 5
Views: 7772

Re: vmware on oss_hdaudio

I've only experienced this with vmware player. And it doesn't have to be a few minutes. I've just started up Windows XP, and had it happen after a minute or two of playing an mp3. I powered off the VM, restarted vmware player, and then had it happened with the windows start up clip. I've only seen t...
by adamk
Sat Oct 30, 2010 2:57 pm
Forum: Linux
Topic: vmware on oss_hdaudio
Replies: 5
Views: 7772

Re: vmware on oss_hdaudio

No ideas?

Adam
by adamk
Tue Oct 26, 2010 11:55 am
Forum: Linux
Topic: vmware on oss_hdaudio
Replies: 5
Views: 7772

vmware on oss_hdaudio

http://webview.npark.com/vmware-hdaudio.ogg Sometimes audio plays just fine under vmware player when I'm using oss_hdaudio. Usually, in fact, it starts out just fine. However, usually after a few minutes, new audio streams in the guest (Windows XP) start to sound like above. Rebooting the guest is n...
by adamk
Sat Oct 23, 2010 8:13 pm
Forum: Linux
Topic: ubuntu_version_hack.inc
Replies: 3
Views: 6374

Re: ubuntu_version_hack.inc

Oh, I know why it's not getting created... I have to copy out this line from setup/Linux/make.local: cp -R prototype/* / If I don't copy that out, make install fails even earlier with: rm -f "/usr/lib/oss"/modules/*.o cp -R prototype/* / cp: cannot overwrite non-directory `/usr/share/man' ...
by adamk
Sat Oct 23, 2010 1:27 pm
Forum: Linux
Topic: ubuntu_version_hack.inc
Replies: 3
Views: 6374

ubuntu_version_hack.inc

The OSS drivers I had installed wouldn't compile against 2.6.36 so I updated to the latest code in mercurial. The build goes fine, but when I run make install, and it tries to compile the modules, it errors out: make[1]: Entering directory `/usr/lib/oss/build' make -C /lib/modules/2.6.36/build M=/us...
by adamk
Wed Aug 18, 2010 11:16 am
Forum: Linux
Topic: vmix and oss_sblive
Replies: 2
Views: 5165

Re: vmix and oss_sblive

For anyone interested, you want to compile this code (courtesy of cesium) and then LD_PRELOAD the resulting library: #define _GNU_SOURCE #include <dlfcn.h> #include <stdio.h> #include <unistd.h> #include <stdlib.h> #include <limits.h> #include <string.h> #include "/usr/lib/oss/include/sys/sound...
by adamk
Mon Aug 16, 2010 10:15 pm
Forum: Linux
Topic: vmix and oss_sblive
Replies: 2
Views: 5165

vmix and oss_sblive

Any chance of seeing vmix and oss_sblive working well together? :-) In addition to the vmware problem (http://4front-tech.com/forum/viewtopic.php?f=3&t=3405&p=13622) I'm also getting the same kind of distortion with old game called MarbleBlast: http://thorn.visualtech.com/marbleblast-with-vm...
by adamk
Thu Jul 29, 2010 7:09 pm
Forum: BSD
Topic: FreeBSD 7.2-RELEASE/amd64 page fault while in kernel mode
Replies: 4
Views: 17953

Re: FreeBSD 7.2-RELEASE/amd64 page fault while in kernel mode

cesium asked me to test this on IRC. I'm not sure if it's related, but I did just get a lockup, even with this patch: bt Tracing pid 12 tid 100033 td 0xc57c2580 oss_memset(ea39d000,0,10000,4,e000,...) at oss_memset+0x14 do_outputintr(c6915408,0,1000,0,e000,...) at do_outputintr+0x278 audio_outputint...
by adamk
Mon Jul 26, 2010 11:56 am
Forum: BSD
Topic: Stuttering and static
Replies: 11
Views: 34378

Re: Stuttering and static

Well we're making some progress...

I finally noticed that the stuttering and static only occur when ossxmix is open and running in the foreground. I had a brief conversation with cesium on #oss last night, and he was thinking it might have something to do with the polling.

Adam
by adamk
Mon May 31, 2010 9:35 pm
Forum: BSD
Topic: oss_sblive system crash FreeBSD 9.0-CURRENT/amd64
Replies: 2
Views: 16607

Re: oss_sblive system crash FreeBSD 9.0-CURRENT/amd64

FYI, I got a new kernel panic today with OSS: db> bt Tracing pid 34193 tid 100344 td 0xca33b9c0 kdb_enter(c0cd96c6,c0cd96c6,c0cdcde4,e826e6a8,1,...) at kdb_enter+0x3a panic(c0cdcde4,ffffffff,97ea,cb,ca33b9c0,...) at panic+0x136 propagate_priority(ca33b9c0,cc48d580,c0cdcd85,2d7,c82c8750,...) at propa...

Go to advanced search