Search found 23 matches

by alexdw
Sat May 06, 2017 2:06 pm
Forum: Announcements
Topic: OSS v4.2 Build 2017
Replies: 7
Views: 3422

Re: OSS v4.2 Build 2017

alexdw wrote:Thanks for the update! :)

Quick question, has the 32-bit (x86) Linux TAR version been uploaded yet?
The link doesn't work for me:
http://www.opensound.com/release/oss-li ... 86.tar.bz2


@dev: Thanks for fixing the link. :)
by alexdw
Tue Apr 25, 2017 9:35 pm
Forum: Announcements
Topic: OSS v4.2 Build 2017
Replies: 7
Views: 3422

Re: OSS v4.2 Build 2017

Sorry for the newb question. I've had my wonderful lynxone in storage since the death of kmixer with vista. I saw this announcement and figured would be the perfect time to rebuild my music machine to use the lynxone again. I've now spent 12+ hours trying to get this pkg to work on FreeBSD 11 with ...
by alexdw
Mon Feb 13, 2017 11:32 pm
Forum: Announcements
Topic: OSS v4.2 Build 2017
Replies: 7
Views: 3422

Re: OSS v4.2 Build 2017

Thanks for the update! :)

Quick question, has the 32-bit (x86) Linux TAR version been uploaded yet?
The link doesn't work for me:
http://www.opensound.com/release/oss-li ... 86.tar.bz2
by alexdw
Mon Jan 09, 2017 11:17 pm
Forum: Linux
Topic: oss not working with kernel 4.8 [SOLVED]
Replies: 22
Views: 2026

Re: oss not working with kernel 4.8 [SOLVED]

I didn't apply the ossvermagic one as I think it was before I started maintaining the AUR packages so I'm not entirely sure if it's always necessary or Arch-specific. Have you found it was necessary for other Linux distros as well? It seems that it does not make any harm for Linux Mint. I was ready...
by alexdw
Mon Jan 09, 2017 10:26 pm
Forum: Linux
Topic: oss not working with kernel 4.8 [SOLVED]
Replies: 22
Views: 2026

Re: oss not working with kernel 4.8 [SOLVED]

Try building from the sources in the git repo: _http://www.opensound.com/ Browse the Open Sound Git Repository: _http://opensound.git.sourceforge.net/git/gitweb.cgi?p=opensound/opensound;a=tree Get the source code using GIT: git clone git://opensound.git.sourceforge.net/gitroot/opensound/opensound ...
by alexdw
Sun Jan 08, 2017 2:39 pm
Forum: Linux
Topic: oss not working with kernel 4.8 [SOLVED]
Replies: 22
Views: 2026

Re: oss not working with kernel 4.8 [SOLVED]

I tried to install the *.rpm package from http://www.opensound.com via dnf. I tried to build oss from source from http://www.4front-tech.com/developer/sources/stable/gpl/ , too. In both cases I had failed to install the oss on my new fedora 25 with kernel 4.8.15-300.fc25.x86_64. I can list error me...
by alexdw
Sun Jan 08, 2017 11:39 am
Forum: Linux
Topic: oss not working with kernel 4.8 [SOLVED]
Replies: 22
Views: 2026

Re: oss not working with kernel 4.8 [SOLVED]

merl wrote:Hi!
Could you please to explain me how to apply this patch on fedora 25?

How are you installing oss on Fedora? Is it done via dnf, RPM, or from source? Do you know if it uses the releases or is there one which points to the git source?
by alexdw
Sun Dec 25, 2016 11:57 pm
Forum: Linux
Topic: oss not working with kernel 4.8 [SOLVED]
Replies: 22
Views: 2026

Re: oss not working with kernel 4.8 [SOLVED]

Thank you very much for all of your work. I confirm that the patch works and I've got working OSS on Ubuntu 16.10 with kernel 4.8. You're welcome, and thank you for posting back to confirm. I submitted this patch (and others) upstream as a merge request on the oss SourceForge git repo (https://sour...
by alexdw
Wed Dec 21, 2016 11:31 pm
Forum: Linux
Topic: oss not working with kernel 4.8 [SOLVED]
Replies: 22
Views: 2026

Re: oss not working with kernel 4.8

For anyone else having this issue, I've made a simple patch (attached, and already included in Arch Linux AUR packages oss and oss-git) to make oss work with CONFIG_HARDENED_USERCOPY in Linux kernel 4.8.

linux-4.8-usercopy.patch.txt
Patch for CONFIG_HARDENED_USERCOPY
(1.28 KiB) Downloaded 53 times
by alexdw
Wed Dec 21, 2016 5:03 pm
Forum: Linux
Topic: oss not working with kernel 4.8 [SOLVED]
Replies: 22
Views: 2026

Re: oss not working with kernel 4.8

OK, I've confirmed that the issue is with CONFIG_HARDENED_USERCOPY added in linux 4.8. I just tried with a custom Arch Linux kernel (4.8.13) without CONFIG_HARDENED_USERCOPY and oss works fine. I'll try to make a patch for oss so it can work with this kernel config (which was added in 4.8 and seems ...
by alexdw
Tue Dec 20, 2016 9:58 pm
Forum: Linux
Topic: oss not working with kernel 4.8 [SOLVED]
Replies: 22
Views: 2026

Re: oss not working with kernel 4.8

Just did a bit of quick research and it looks like there were some changes to the "copy_to_user" and related functions in kernel 4.8: https://kernelnewbies.org/Linux_4.8#head-51078e394a4497e6d1b9c8a7ffaf0c69eeba06e9 https://lwn.net/Articles/695991/ https://www.phoronix.com/scan.php?page=ne...
by alexdw
Mon Oct 31, 2016 12:18 am
Forum: Linux
Topic: oss not working with kernel 4.8 [SOLVED]
Replies: 22
Views: 2026

oss not working with kernel 4.8 [SOLVED]

As the subject says, oss is not working for me with the latest kernel versions - specifically 4.8.4 on Arch Linux. It seems to compile and install OK (using any of the various AUR packages: oss, oss-git, oss-nonfree) but osstest gives a segmentation fault: Oct 31 00:07:03 Alex-Arch01 kernel: usercop...
by alexdw
Mon Jun 01, 2015 10:53 pm
Forum: Linux
Topic: OSS fails to build against Linux 4.0 [SOLVED]
Replies: 12
Views: 18441

Re: OSS fails to build against Linux 4.0 [SOLVED]

it appears that it wasn't Linux 4.0.4 which prevents me from building oss but a new version of gcc (5.1.0). It may happen. Similar problems were reported for gcc-4.8 (they were somehow fixed). I have made a quick and dirty patch for this (see attached) based on the information in the GCC 5 porting ...
by alexdw
Sun May 31, 2015 9:55 am
Forum: Linux
Topic: OSS fails to build against Linux 4.0 [SOLVED]
Replies: 12
Views: 18441

Re: OSS fails to build against Linux 4.0 [SOLVED]

Seems to be broken again in Linux 4.0.4. :( Not at all... Working just fine, here with Linux v4.0.4: it both auto-compiled the new modules on kernel update and I still can build the package under v4.0.4. Thanks for the information. You are right - it appears that it wasn't Linux 4.0.4 which prevent...
by alexdw
Wed May 27, 2015 9:46 pm
Forum: Linux
Topic: OSS fails to build against Linux 4.0 [SOLVED]
Replies: 12
Views: 18441

Re: OSS fails to build against Linux 4.0 [SOLVED]

Seems to be broken again in Linux 4.0.4. :(

Go to advanced search