Search found 1259 matches

by igorzwx
Sun Jul 02, 2017 1:05 pm
Forum: Linux
Topic: Kernel 4.12
Replies: 5
Views: 11150

Re: Kernel 4.12

So, I got a Gigabyte motherboard and as it turns out only kernel 4.12 has the IRQ fixes needed to run it. The problem is, OSS doesn't work with 4.12. It fails to compile oss_usb and while it will start, it encounters a problem if you try to play a sound. Could you please provide some info about you...
by igorzwx
Tue Feb 14, 2017 3:07 pm
Forum: Linux
Topic: ossrecord - permission denied even as root
Replies: 10
Views: 17248

Re: ossrecord - permission denied even as root

waterlaz wrote:Well.. now I don't have the permission denied error, but the mic still doesn't work, even though I've tried all the possible settings in the mixer.


Post here the output of this command:

Code: Select all

$ find /dev/oss -type c
by igorzwx
Tue Jan 10, 2017 9:43 pm
Forum: Linux
Topic: oss not working with kernel 4.8 [SOLVED]
Replies: 22
Views: 26027

Re: oss not working with kernel 4.8 [SOLVED]

kmod-link.patch was designed to fix a sort of "actual bug in OSS": _https://aur.archlinux.org/pkgbase/oss/?comments=all toksik commented on 2013-11-11 18:14 I seem to have finally discovered the actual bug in OSS and was able to fix it properly. This removes the dependency on gcc-4.7 and ...
by igorzwx
Mon Jan 09, 2017 11:50 pm
Forum: Linux
Topic: oss not working with kernel 4.8 [SOLVED]
Replies: 22
Views: 26027

Re: oss not working with kernel 4.8 [SOLVED]

I think I assumed that they were Arch-specific because some of the kernel patches were applied upstream a couple of years ago Some of them might be Arch-specific: $ cat soundon.patch | grep Fix + # Fix for compatibility with Arch's directory structure + # Fix for compatibility with Arch's directory...
by igorzwx
Mon Jan 09, 2017 10:50 pm
Forum: Linux
Topic: oss not working with kernel 4.8 [SOLVED]
Replies: 22
Views: 26027

Re: oss not working with kernel 4.8 [SOLVED]

I didn't apply the ossvermagic one as I think it was before I started maintaining the AUR packages so I'm not entirely sure if it's always necessary or Arch-specific. Have you found it was necessary for other Linux distros as well? It seems that it does not make any harm for Linux Mint. I was ready...
by igorzwx
Mon Jan 09, 2017 10:18 pm
Forum: Linux
Topic: oss not working with kernel 4.8 [SOLVED]
Replies: 22
Views: 26027

Re: oss not working with kernel 4.8 [SOLVED]

Try building from the sources in the git repo: _http://www.opensound.com/ Browse the Open Sound Git Repository: _http://opensound.git.sourceforge.net/git/gitweb.cgi?p=opensound/opensound;a=tree Get the source code using GIT: git clone git://opensound.git.sourceforge.net/gitroot/opensound/opensound ...
by igorzwx
Sun Jan 08, 2017 8:21 pm
Forum: Linux
Topic: oss not working with kernel 4.8 [SOLVED]
Replies: 22
Views: 26027

Re: oss not working with kernel 4.8 [SOLVED]

Thanks for your reply, igorzwx! I downloaded the last version with patch via git, but get same errors... Maybe, it depends on gcc version? My is 6.3.1 20161221 In any case, the git version does not have the closed source driver for your Lynx soundcard. Sound Card: Lynx L-22 OS: Fedora Linux 25 You ...
by igorzwx
Sun Jan 08, 2017 4:55 pm
Forum: Linux
Topic: oss not working with kernel 4.8 [SOLVED]
Replies: 22
Views: 26027

Re: oss not working with kernel 4.8 [SOLVED]

I tried to install the *.rpm package from _http://www.opensound.com via dnf. I tried to build oss from source from _http://www.4front-tech.com/developer/sources/stable/gpl/ , too. In both cases I had failed to install the oss on my new fedora 25 with kernel 4.8.15-300.fc25.x86_64. I can list error ...
by igorzwx
Sun Jan 08, 2017 3:48 pm
Forum: Linux
Topic: oss not working with kernel 4.8 [SOLVED]
Replies: 22
Views: 26027

Re: oss not working with kernel 4.8 [SOLVED]

I tried to install the *.rpm package… If rpm-package is needed, it can be produced with Linux Mint LiveCD _http://ossnext.trueinstruments.com/forum/viewtopic.php?f=3&t=5828 If the patches are already applied, you do not need to patch the source with quilt. 1. Install the package manager for RPM...
by igorzwx
Fri Jan 06, 2017 3:34 pm
Forum: Linux
Topic: Script to fix sound for skype-oss and "exclusive mode"
Replies: 2
Views: 14562

Re: Script to fix sound for skype-oss and "exclusive mode"

A simple solution: $ cat killaudio.sh #!/bin/bash # Script to free the sound device for "skype_oss_wrapper" and/or "exclusive mode", e.g. "ossplay -R" # 1: "find" will find all audio devices of OSS4 # 2: "fuser" will kill all audio apps # 3: The OSS ...
by igorzwx
Thu Dec 29, 2016 9:26 pm
Forum: Linux
Topic: ossrecord - permission denied even as root
Replies: 10
Views: 17248

Re: ossrecord - permission denied even as root

Try something like this ("hdaudio_noskip=7"): _http://ossnext.trueinstruments.com/forum/viewtopic.php?f=16&t=4446&p=17828#p17828 The same problem with the same HDA codec AD1984 _http://ossnext.trueinstruments.com/forum/viewtopic.php?f=3&t=3887 PROBLEM: "OSS doesn't identif...
by igorzwx
Mon Dec 26, 2016 5:20 pm
Forum: Linux
Topic: ossrecord - permission denied even as root
Replies: 10
Views: 17248

Re: ossrecord - permission denied even as root

This has been done in root. I've just replaced the prompt with $ myself. But ok... pidgin tmp # whoami root pidgin tmp # ossrecord -i? /dev/dsp: Permission denied pidgin tmp # ossrecord -d/dev/dsp assdf.wav /dev/dsp: Permission denied Does your "root" have rw access to it? Post here the o...
by igorzwx
Thu Dec 22, 2016 6:30 pm
Forum: Linux
Topic: ossrecord - permission denied even as root
Replies: 10
Views: 17248

Re: ossrecord - permission denied even as root

$ ossrecord -i? /dev/dsp: Permission denied All of this with root. "$" does not mean "root". The root terminal is usually "#" /dev/dsp: Permission denied This error will occur, if the user does not have permission to use the audio device: Error: /dev/dsp: Permission de...
by igorzwx
Sat Sep 10, 2016 2:38 pm
Forum: Linux
Topic: oss_hdaudio broken with Linux 4.7.2 (Intel IOMMU conflicts with OSSv4) [semi-SOLVED]
Replies: 9
Views: 13459

Re: oss_hdaudio broken with Linux 4.7.2 (Intel IOMMU conflicts with OSSv4) [semi-SOLVED]

Thank You Igor, but I prefer Gentoo. Not Arch because I would start using AUR and when you do, your distribution starts slowly migrate to almost full AUR, and AUR is far too weak in comparison with Gentoo Ebuild system. Not *buntu simply because it is release based, I ran from "Windows" w...
by igorzwx
Sat Sep 10, 2016 2:11 pm
Forum: Linux
Topic: oss_hdaudio broken with Linux 4.7.2 (Intel IOMMU conflicts with OSSv4) [semi-SOLVED]
Replies: 9
Views: 13459

Re: oss_hdaudio broken with Linux 4.7.2 (Intel IOMMU conflicts with OSSv4) [semi-SOLVED]

Yes, I've also seen that topic. I tried iommu=pt, no luck for me. It seems that it works for Ubuntu users: Re: My HDAudio is no longer recognized Postby keantoken » Wed Feb 19, 2014 10:10 pm Well, using the iommu=pt kernel option works, so I don't have to disable IOMMU. Finally, I have sound. _http...

Go to advanced search