[Fixed] WMMixer and OSS4

OSS related discussion in general (i.e. not limited to Linux/Solaris/BSD)

Moderators: hannu, dev, cesium

Xylemon
Member
Posts: 28
Joined: Tue Aug 19, 2014 2:53 pm
Sound Card: Creative X-Fi Xtreme
OS: Slackware Linux

[Fixed] WMMixer and OSS4

Postby Xylemon » Mon Sep 29, 2014 5:37 pm

Hello, I've been desperately trying to get this update to wmmixer working and so far I've had no luck. I thought it had to do with permissions on /dev/mixer but it seems to not be the case. Basically despite whatever I have setup in the configuration file, it spits out:

wmmixer : Sorry, no supported channels found.

The specific version I'm talking about is here: https://github.com/puyo/wmmixer-oss4

The author is no longer working on this dockapp and hasn't touched it in years. Any help would be very appreciated.
Last edited by Xylemon on Sat Oct 04, 2014 5:17 am, edited 1 time in total.

seawright
Member
Posts: 94
Joined: Sat Jan 06, 2007 9:10 pm
Location: Hampshire UK

Re: WMMixer and OSS4

Postby seawright » Thu Oct 02, 2014 8:12 pm

Can you adjust volume with ossxmix?
If so, try:

Code: Select all

echo "addchannel vmix0-outvol 0" >~/.wmmixer
regards
Clive

Xylemon
Member
Posts: 28
Joined: Tue Aug 19, 2014 2:53 pm
Sound Card: Creative X-Fi Xtreme
OS: Slackware Linux

Re: WMMixer and OSS4

Postby Xylemon » Fri Oct 03, 2014 6:46 pm

seawright wrote:Can you adjust volume with ossxmix?
If so, try:

Code: Select all

echo "addchannel vmix0-outvol 0" >~/.wmmixer


Yes I can, also did you mean ~/.wmmixer/home.wmmixer? Because that's where my config file is. Doing that produces:

./wmmixer: line 1: addchannel: command not found

Which is odd.

seawright
Member
Posts: 94
Joined: Sat Jan 06, 2007 9:10 pm
Location: Hampshire UK

Re: WMMixer and OSS4

Postby seawright » Fri Oct 03, 2014 8:35 pm

Have you compiled wmmixer to use a non-standard configuration file?
If not it should be ~/.wmmixer which appears to be a directory on your box.
if launching wmmixer from an xterm as opposed to a drawer, does it report "Compiled with OSS version 40100"?
Could you post the output of:

Code: Select all

ossmix -D |grep slider
and indicate by the number in the first field which slider(s) you want wmmixer to control?
regards

Clive

Xylemon
Member
Posts: 28
Joined: Tue Aug 19, 2014 2:53 pm
Sound Card: Creative X-Fi Xtreme
OS: Slackware Linux

Re: WMMixer and OSS4

Postby Xylemon » Sat Oct 04, 2014 5:16 am

seawright wrote:Have you compiled wmmixer to use a non-standard configuration file?
If not it should be ~/.wmmixer which appears to be a directory on your box.
if launching wmmixer from an xterm as opposed to a drawer, does it report "Compiled with OSS version 40100"?
Could you post the output of:

Code: Select all

ossmix -D |grep slider
and indicate by the number in the first field which slider(s) you want wmmixer to control?


Haha! I'm an idiot, because I misread "cp home.wmmixer ~/.wmmixer" as putting a home.wmmixer file in a .wmmixer folder! Now wmmixer works perfectly! Thanks for the help.


Return to “General Discussion”

Who is online

Users browsing this forum: No registered users and 2 guests