Problems getting recording to work

OSS specific Linux discussion (x86/amd64)

Moderators: hannu, dev, cesium

New Member
Posts: 2
Joined: Sat Aug 20, 2011 5:32 am

Problems getting recording to work

Postby delan » Sat Aug 20, 2011 5:55 am


I'm using Gentoo with OSS 4, with an Intel HDA device. Playback works flawlessly, but recording is something I can't get working. My current physical setup is very simple: stereo output on the green jack, and stereo input on the pink jack.

Code: Select all

delan@mercury ~ $ ossinfo
Version info: OSS 4.2 (b 2004/201107201430) (0x00040100) OSS_HG
Hg revision: changeset: 935:2bf7db11c82d, tag: tip, date: Wed Jul 20 03:58:10 2011 +0300, summary: Change SOUND_MASK_VOLUME to SOUND_MASK_PCM after switching
Platform: Linux/x86_64 3.0.1-gentoo #1 SMP Mon Aug 15 19:30:58 WST 2011 (mercury)

Number of audio devices:        10
Number of audio engines:        14
Number of MIDI devices:         0
Number of mixer devices:        1

Device objects
 0: osscore0 OSS core services
 1: oss_hdaudio0 Intel HD Audio interrupts=1112 (1112)
    HD Audio controller Intel HD Audio
    Vendor ID    0x80863a3e
    Subvendor ID 0x1458a102
     Codec  2: ALC885 (0x10ec0885/0x1458a102)

MIDI devices (/dev/midi*)

Mixer devices
 0: High Definition Audio ALC885 (Mixer 0 of device object 1)

Audio devices
HD Audio play front               /dev/oss/oss_hdaudio0/pcm0  (device index 0)
HD Audio play rear                /dev/oss/oss_hdaudio0/pcm1  (device index 1)
HD Audio play center/LFE          /dev/oss/oss_hdaudio0/pcm2  (device index 2)
HD Audio play side                /dev/oss/oss_hdaudio0/pcm3  (device index 3)
HD Audio play pcm4                /dev/oss/oss_hdaudio0/pcm4  (device index 4)
HD Audio play spdif-out           /dev/oss/oss_hdaudio0/spdout0  (device index 5)
HD Audio rec mix                  /dev/oss/oss_hdaudio0/pcmin0  (device index 6)
HD Audio rec mix                  /dev/oss/oss_hdaudio0/pcmin1  (device index 7)
HD Audio rec mix                  /dev/oss/oss_hdaudio0/pcmin2  (device index 8)
HD Audio rec spdifin              /dev/oss/oss_hdaudio0/spdin0  (device index 9)

  /dev/dsp -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_in -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_out -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_ac3 -> /dev/oss/oss_hdaudio0/spdout0
  /dev/dsp_mmap -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_multich -> /dev/oss/oss_hdaudio0/pcm0

I have initially reset my mixer settings to the OSS defaults, which are:

Code: Select all

Selected mixer 0/High Definition Audio ALC885
Known controls are: <front|rear|center/LFE|side|pcm4|input> (currently front) [<leftvol>:<rightvol>] (currently 29.9:29.9 dB) ON|OFF (currently OFF) <front|rear|center/LFE|side|pcm4|input> (currently center/LFE) [<leftvol>:<rightvol>] (currently 29.9:29.9 dB) ON|OFF (currently OFF) <front|rear|center/LFE|side|pcm4|input> (currently rear) [<leftvol>:<rightvol>] (currently 29.9:29.9 dB) ON|OFF (currently OFF)
jack.gray.mode <front|rear|center/LFE|side|pcm4|input> (currently pcm4)
jack.gray [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.gray.mute ON|OFF (currently OFF) <front|rear|center/LFE|side|pcm4|input> (currently front) [<leftvol>:<rightvol>] (currently 29.9:29.9 dB) ON|OFF (currently OFF)
jack.fp-pink.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.fp-pink [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.fp-pink.mute ON|OFF (currently OFF) <front|rear|center/LFE|side|pcm4|input> (currently input) [<leftvol>:<rightvol>] (currently 29.9:29.9 dB) ON|OFF (currently OFF)
jack.fp-green.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.fp-green [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.fp-green.mute ON|OFF (currently OFF)
record.mix.mute.mic1 ON|OFF (currently OFF)
record.mix.mute.fp-mic1 ON|OFF (currently OFF)
record.mix.mute.linein1 ON|OFF (currently OFF)
record.mix.mute.fp-headphone1 ON|OFF (currently OFF) ON|OFF (currently OFF)
record.mix.mute.white1 ON|OFF (currently OFF)
record.mix.mute.green1 ON|OFF (currently OFF)
record.mix.mute.black1 ON|OFF (currently OFF)
record.mix.mute.orange1 ON|OFF (currently OFF)
record.mix.mute.gray1 ON|OFF (currently OFF)
record.mix.mute.input-mix1 ON|OFF (currently OFF)
record.mix1 [<leftvol>:<rightvol>] (currently 37.9:37.9 dB)
record.mix.mute.mic2 ON|OFF (currently OFF)
record.mix.mute.fp-mic2 ON|OFF (currently OFF)
record.mix.mute.linein2 ON|OFF (currently OFF)
record.mix.mute.fp-headphone2 ON|OFF (currently OFF) ON|OFF (currently OFF)
record.mix.mute.white2 ON|OFF (currently OFF)
record.mix.mute.green2 ON|OFF (currently OFF)
record.mix.mute.black2 ON|OFF (currently OFF)
record.mix.mute.orange2 ON|OFF (currently OFF)
record.mix.mute.gray2 ON|OFF (currently OFF)
record.mix.mute.input-mix2 ON|OFF (currently OFF)
record.mix2 [<leftvol>:<rightvol>] (currently 37.9:37.9 dB)
record.mix.mute.mic3 ON|OFF (currently OFF)
record.mix.mute.fp-mic3 ON|OFF (currently OFF)
record.mix.mute.linein3 ON|OFF (currently OFF)
record.mix.mute.fp-headphone3 ON|OFF (currently OFF) ON|OFF (currently OFF)
record.mix.mute.white3 ON|OFF (currently OFF)
record.mix.mute.green3 ON|OFF (currently OFF)
record.mix.mute.black3 ON|OFF (currently OFF)
record.mix.mute.orange3 ON|OFF (currently OFF)
record.mix.mute.gray3 ON|OFF (currently OFF)
record.mix.mute.input-mix3 ON|OFF (currently OFF)
record.mix3 [<leftvol>:<rightvol>] (currently 37.9:37.9 dB)
misc.mic [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.fp-mic [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.linein [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.fp-headphone [<leftvol>:<rightvol>] (currently 38.9:38.9 dB) [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.white [<leftvol>:<rightvol>] (currently 38.9:38.9 dB) [<leftvol>:<rightvol>] (currently 38.9:38.9 dB) [<leftvol>:<rightvol>] (currently 38.9:38.9 dB) [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.gray [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.input-mix <mic|fp-mic|linein|int-cd> (currently mic)
misc.front-mute ON|OFF (currently OFF)
misc.input-mix-mute1 ON|OFF (currently OFF)
misc.front1 [<leftvol>:<rightvol>] (currently 51.9:51.9 dB)
misc.front2 <front|input-mix> (currently front)
misc.rear-mute ON|OFF (currently OFF)
misc.input-mix-mute2 ON|OFF (currently OFF)
misc.rear1 [<leftvol>:<rightvol>] (currently 51.9:51.9 dB)
misc.rear2 <rear|input-mix> (currently rear) ON|OFF (currently OFF)
misc.input-mix-mute3 ON|OFF (currently OFF) [<leftvol>:<rightvol>] (currently 51.9:51.9 dB) <center/LFE|input-mix> (currently center/LFE)
misc.side-mute ON|OFF (currently OFF)
misc.input-mix-mute4 ON|OFF (currently OFF)
misc.side1 [<leftvol>:<rightvol>] (currently 51.9:51.9 dB)
misc.side2 <side|input-mix> (currently side)
misc.pcm4-mute ON|OFF (currently OFF)
misc.input-mix-mute5 ON|OFF (currently OFF)
misc.pcm41 [<leftvol>:<rightvol>] (currently 51.9:51.9 dB)
misc.pcm42 <pcm4|input-mix> (currently pcm4)
vmix0-enable ON|OFF (currently ON)
vmix0-rate <decimal value> (currently 48000) (Read-only)
vmix0-channels <Stereo|Multich> (currently Stereo)
vmix0-src <Fast|High|OFF> (currently Fast)
vmix0-outvol <monovol> (currently 25.0 dB)
vmix0-invol <monovol> (currently 25.0 dB)
vmix0.pcm10 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm11 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm12 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm13 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)

I have noticed that, oddly, by default, = front. From what I can gather, it really should be input, so I have tried changing it to that.

Doing this has the interesting effect of any input to the pink jack being echoed back to the green jack, or in other words, I can hear what I am saying. I have also noticed that setting misc.input-mix-mute1 = OFF disables this echoing.

However, nothing I have tried makes the input show up in the vmix0-invu or even reach vmix0, nor can I record with Skype (the version, statically linked for OSS) or ossrecord.

Could anyone please help me get audio recording working?

Posts: 902
Joined: Sun Aug 12, 2007 12:51 am

Re: Problems getting recording to work

Postby cesium » Sat Aug 20, 2011 8:24 am

"ossmix input"
"ossmix" 0

The reason you the echo is because sets (I believe) passthrough volume, definitely not record volume. Recording volume is set by misc.mic or record.mix (don't exactly recall). You can then test recording via 'ossrecord - | ossplay -".

Return to “Linux”

Who is online

Users browsing this forum: No registered users and 1 guest