OSS4 O_EXCL works, but vmix does not

OSS specific Linux discussion (x86/amd64)

Moderators: hannu, dev, cesium

cy1
New Member
Posts: 2
Joined: Fri Mar 22, 2013 3:43 am

OSS4 O_EXCL works, but vmix does not

Postby cy1 » Fri Mar 22, 2013 3:58 am

When my (vast majority) of sound applications open the pcm device, they do so without O_EXCL, and no sound comes out. When osstest does it uses O_EXCL, and I can hear sound coming out of the speakers. None of them produce any error messages that sound failed to open or is failing to be delivered anywhere. When I open up ossmix it shows vmix is there and turned on, but I'm not entirely familiar with its parameters. Could you take a look at it and see what I'm doing perhaps to muck things up?

Code: Select all

Selected mixer 0/High Definition Audio ALC662
Known controls are:
jack.green.mode <front|input> (currently front)
jack.green.mute ON|OFF (currently OFF)
jack.green.front [<leftvol>:<rightvol>] (currently 63.9:63.9 dB)
jack.green.front-mute ON|OFF (currently OFF)
jack.green.mix-mute ON|OFF (currently OFF)
jack.pink.mode <c/lfe|input> (currently c/lfe)
jack.pink [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.pink.mute ON|OFF (currently OFF)
jack.pink.center/lfe [<leftvol>:<rightvol>] (currently 51.9:51.9 dB)
jack.pink.center/lfe-mute ON|OFF (currently OFF)
jack.pink.mix-mute ON|OFF (currently OFF)
jack.fp-pink.mode <front|c/lfe|input> (currently front)
jack.fp-pink [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.fp-pink.mute ON|OFF (currently OFF)
jack.blue.mode <rear|input> (currently rear)
jack.blue.mute ON|OFF (currently OFF)
jack.blue.rear [<leftvol>:<rightvol>] (currently 51.9:51.9 dB)
jack.blue.rear-mute ON|OFF (currently OFF)
jack.blue.mix-mute ON|OFF (currently OFF)
jack.fp-green.mode <front|c/lfe|input> (currently front)
jack.fp-green [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.fp-green.mute ON|OFF (currently OFF)
record.mix.mute.c/lfe1 ON|OFF (currently OFF)
record.mix.mute.fp-mic1 ON|OFF (currently OFF)
record.mix.mute.rear1 ON|OFF (currently OFF)
record.mix.mute.fp-headphone1 ON|OFF (currently OFF)
record.mix.mute.front1 ON|OFF (currently OFF)
record.mix.mute.mix1 ON|OFF (currently OFF)
record.mix1 [<leftvol>:<rightvol>] (currently 32.9:32.9 dB)
record.mix.mute.c/lfe2 ON|OFF (currently OFF)
record.mix.mute.fp-mic2 ON|OFF (currently OFF)
record.mix.mute.rear2 ON|OFF (currently OFF)
record.mix.mute.fp-headphone2 ON|OFF (currently OFF)
record.mix.mute.front2 ON|OFF (currently OFF)
record.mix.mute.mix2 ON|OFF (currently OFF)
record.mix2 [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.c/lfe [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.fp-mic [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.rear [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.fp-headphone [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.front [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.mix <c/lfe|fp-mic|rear> (currently c/lfe)
vmix0-enable ON|OFF (currently ON)
vmix0-rate <decimal value> (currently 48000) (Read-only)
vmix0-channels <Stereo|Multich> (currently Multich)
vmix0-src <Fast|High|OFF> (currently Fast)
vmix0-outvol <monovol> (currently 25.0 dB)
vmix0-invol <monovol> (currently 25.0 dB)
vmix0.pcm5 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB) ("player")
vmix0.pcm6 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm7 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm8 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)


It seems peculiar that vmix starts from pcm5, when I only have pcm0 1 and 2 in /dev/oss.

My sound card is an ATI thing, on-board. It has three stereo jacks built-in on the back panel (green, pink and blue). On the motherboard there's a 7-pin 2x4 rectangle labeled "Front Audio Connector" that I can't fathom is anything but a way to add more jacks that is harmless if left unused. AMD motherboard. I don't think it's hardware though, because as I said when osstest opened pcm0 using O_EXCL sound came out perfectly fine. As this sound card is a glorified radio station I'd be happy to set O_EXCL myself, if I wouldn't have to reapply the patch every damn time gstreamer updates.

Here's the lspci -v:

Code: Select all

00:01.1 Audio device: Advanced Micro Devices [AMD] nee ATI Trinity HDMI Audio Controller
        Subsystem: Advanced Micro Devices [AMD] nee ATI Trinity HDMI Audio Controller
        Flags: bus master, fast devsel, latency 0, IRQ 10
        Memory at fef44000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 3
        Capabilities: [58] Express Root Complex Integrated Endpoint, MSI 00
        Capabilities: [a0] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>


And in dmesg when I ran soundon, this popped up:

Code: Select all

[ 2115.751486] osscore: Unrecognized device class 6 for dev 0
[ 2342.394168] osscore: Unrecognized device class 6 for dev 0
[ 2672.004940] osscore: Output timed out on audio engine 2/'HD Audio play center/LFE' (count=0)
[ 2672.114550] osscore: Output timed out (sync) on audio engine 2


Anyone who sees something wrong with this picture please, let me know!

igorzwx
Known Member
Posts: 1246
Joined: Sun Jun 28, 2009 9:31 pm

Re: OSS4 O_EXCL works, but vmix does not

Postby igorzwx » Fri Mar 22, 2013 4:09 pm

cy1 wrote:When my (vast majority) of sound applications open the pcm device, they do so without O_EXCL, and no sound comes out. When osstest does it uses O_EXCL, and I can hear sound coming out of the speakers. None of them produce any error messages that sound failed to open or is failing to be delivered anywhere. When I open up ossmix it shows vmix is there and turned on, but I'm not entirely familiar with its parameters. Could you take a look at it and see what I'm doing perhaps to muck things up?

Code: Select all

Selected mixer 0/High Definition Audio ALC662
Known controls are:
jack.green.mode <front|input> (currently front)
jack.green.mute ON|OFF (currently OFF)
jack.green.front [<leftvol>:<rightvol>] (currently 63.9:63.9 dB)
jack.green.front-mute ON|OFF (currently OFF)
jack.green.mix-mute ON|OFF (currently OFF)
jack.pink.mode <c/lfe|input> (currently c/lfe)
jack.pink [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.pink.mute ON|OFF (currently OFF)
jack.pink.center/lfe [<leftvol>:<rightvol>] (currently 51.9:51.9 dB)
jack.pink.center/lfe-mute ON|OFF (currently OFF)
jack.pink.mix-mute ON|OFF (currently OFF)
jack.fp-pink.mode <front|c/lfe|input> (currently front)
jack.fp-pink [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.fp-pink.mute ON|OFF (currently OFF)
jack.blue.mode <rear|input> (currently rear)
jack.blue.mute ON|OFF (currently OFF)
jack.blue.rear [<leftvol>:<rightvol>] (currently 51.9:51.9 dB)
jack.blue.rear-mute ON|OFF (currently OFF)
jack.blue.mix-mute ON|OFF (currently OFF)
jack.fp-green.mode <front|c/lfe|input> (currently front)
jack.fp-green [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.fp-green.mute ON|OFF (currently OFF)
record.mix.mute.c/lfe1 ON|OFF (currently OFF)
record.mix.mute.fp-mic1 ON|OFF (currently OFF)
record.mix.mute.rear1 ON|OFF (currently OFF)
record.mix.mute.fp-headphone1 ON|OFF (currently OFF)
record.mix.mute.front1 ON|OFF (currently OFF)
record.mix.mute.mix1 ON|OFF (currently OFF)
record.mix1 [<leftvol>:<rightvol>] (currently 32.9:32.9 dB)
record.mix.mute.c/lfe2 ON|OFF (currently OFF)
record.mix.mute.fp-mic2 ON|OFF (currently OFF)
record.mix.mute.rear2 ON|OFF (currently OFF)
record.mix.mute.fp-headphone2 ON|OFF (currently OFF)
record.mix.mute.front2 ON|OFF (currently OFF)
record.mix.mute.mix2 ON|OFF (currently OFF)
record.mix2 [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.c/lfe [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.fp-mic [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.rear [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.fp-headphone [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.front [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.mix <c/lfe|fp-mic|rear> (currently c/lfe)
vmix0-enable ON|OFF (currently ON)
vmix0-rate <decimal value> (currently 48000) (Read-only)
vmix0-channels <Stereo|Multich> (currently Multich)
vmix0-src <Fast|High|OFF> (currently Fast)
vmix0-outvol <monovol> (currently 25.0 dB)
vmix0-invol <monovol> (currently 25.0 dB)
vmix0.pcm5 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB) ("player")
vmix0.pcm6 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm7 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm8 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)


It seems peculiar that vmix starts from pcm5, when I only have pcm0 1 and 2 in /dev/oss.

My sound card is an ATI thing, on-board. It has three stereo jacks built-in on the back panel (green, pink and blue). On the motherboard there's a 7-pin 2x4 rectangle labeled "Front Audio Connector" that I can't fathom is anything but a way to add more jacks that is harmless if left unused. AMD motherboard. I don't think it's hardware though, because as I said when osstest opened pcm0 using O_EXCL sound came out perfectly fine. As this sound card is a glorified radio station I'd be happy to set O_EXCL myself, if I wouldn't have to reapply the patch every damn time gstreamer updates.

Here's the lspci -v:

Code: Select all

00:01.1 Audio device: Advanced Micro Devices [AMD] nee ATI Trinity HDMI Audio Controller
        Subsystem: Advanced Micro Devices [AMD] nee ATI Trinity HDMI Audio Controller
        Flags: bus master, fast devsel, latency 0, IRQ 10
        Memory at fef44000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 3
        Capabilities: [58] Express Root Complex Integrated Endpoint, MSI 00
        Capabilities: [a0] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>


And in dmesg when I ran soundon, this popped up:

Code: Select all

[ 2115.751486] osscore: Unrecognized device class 6 for dev 0
[ 2342.394168] osscore: Unrecognized device class 6 for dev 0
[ 2672.004940] osscore: Output timed out on audio engine 2/'HD Audio play center/LFE' (count=0)
[ 2672.114550] osscore: Output timed out (sync) on audio engine 2


Anyone who sees something wrong with this picture please, let me know!


This is strange:

Code: Select all

[your ossmix]
jack.pink.mode <c/lfe|input> (currently c/lfe)


You may want to use microphone for input. Right?
Or you are trying to configure surround playback?

gstreamer is not likely to work out of the box. It might be configured with special scripts, or it should be hacked/recompiled in some way.
You may also need to install/recompile "gnome-media" and other sorts of the crap.
[All these can be found in the ancient threads on this forum].

Do you really need such crap?
I do not use it at all.
What kind of crappy applications are you going to use with gstreamer?


You may try:

Code: Select all

ossinfo -a


Then:

Code: Select all

$ osstest 0
$ osstest -V 0

$ osstest 1
$ osstest -V 1

$ osstest 2
$ osstest -V 2

[and so on]


EXAMPLE:

Code: Select all

$ osstest -V 0
Sound subsystem and version: OSS 4.2 (b 2006/201303161803) (0x00040100)
Platform: Linux/i686 3.5.0-25-generic #39-Ubuntu SMP Mon Feb 25 19:02:34 UTC 2013

*** Scanning sound adapter #-1 ***
/dev/oss/oss_hdaudio0/pcm0 (audio engine 0): HD Audio play front
- Performing audio playback test...
  <left> OK <right> OK <stereo> OK <measured srate 47963.00 Hz (-0.08%)>

*** All tests completed OK ***


Code: Select all

$ man osstest
          It is possible to test just one of the available  audio  devices  by
          giving  its  number on command line (for example osstest 1). Use the
          device index numbers reported by "ossinfo -a".

          Virtual mixer devices will not be tested. Use the  -V  command  line
          option to force test of virtual devices.


Green = Front (output = playback)
Pink = Mic (input = recording)
Blue = Line-in (input = recording)

All of them can be used for playback and recording.

Some motherboards may not correctly initialize the jacks according
to their color and functionality but in general here's the
configuration that should generally be followed:

Orange = Center/LFE o Blue = Line-in
Black = Rear o Green = Front
Grey = Side o Pink = Mic

Some Azalia codecs support front panel connectors and so if you see
fp-green and fp-pink connectors, then these are for front panel
speaker and mic/line-in Jacks.

There is a function selector for most of the analog audio jacks (for example
connector.pink.mode). This selector is used to control if the jack is used
as an input (microphone or line in) or output (front, rear, side, speaker,
etc). http://manuals.opensound.com/usersguide ... audio.html


EXAMPLE:

Code: Select all

$ ossmix
Selected mixer 0/High Definition Audio ALC887
Known controls are:
codec3.jack.green.mode <front|input> (currently front)
codec3.jack.green.mute ON|OFF (currently OFF)
codec3.jack.green.front [<leftvol>:<rightvol>] (currently 52.9:52.9 dB)
codec3.jack.green.front-mute ON|OFF (currently OFF)

[HW Mixing is dissabled. "ON" means "OFF" (muted), "OFF" means "ON" (unmuted)]
codec3.jack.green.input-mix-mut ON|OFF (currently ON)

codec3.jack.pink.mode <front|rear|center/LFE|side|pcm4|input> (currently input)
codec3.jack.pink [<leftvol>:<rightvol>] (currently 9.9:9.9 dB)
codec3.jack.pink.mute ON|OFF (currently OFF)
codec3.jack.fp-pink.mode <front|rear|center/LFE|side|pcm4|input> (currently input)
codec3.jack.fp-pink [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
codec3.jack.fp-pink.mute ON|OFF (currently OFF)
codec3.jack.blue.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
codec3.jack.blue [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
codec3.jack.blue.mute ON|OFF (currently OFF)
codec3.jack.fp-green.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
codec3.jack.fp-green [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
codec3.jack.fp-green.mute ON|OFF (currently OFF)
codec3.record.mix.mute.mic1 ON|OFF (currently OFF)
codec3.record.mix.mute.fp-mic1 ON|OFF (currently OFF)
codec3.record.mix.mute.linein1 ON|OFF (currently OFF)
codec3.record.mix.mute.fp-head1 ON|OFF (currently OFF)
codec3.record.mix.mute.int-cd1 ON|OFF (currently OFF)
codec3.record.mix.mute.front1 ON|OFF (currently OFF)
codec3.record.mix.mute.input-m1 ON|OFF (currently OFF)
codec3.record.mix1 [<leftvol>:<rightvol>] (currently 17.9:17.9 dB)
codec3.record.mix.mute.mic2 ON|OFF (currently OFF)
codec3.record.mix.mute.fp-mic2 ON|OFF (currently OFF)
codec3.record.mix.mute.linein2 ON|OFF (currently OFF)
codec3.record.mix.mute.fp-head2 ON|OFF (currently OFF)
codec3.record.mix.mute.int-cd2 ON|OFF (currently OFF)
codec3.record.mix.mute.front2 ON|OFF (currently OFF)
codec3.record.mix.mute.input-m2 ON|OFF (currently OFF)
codec3.record.mix2 [<leftvol>:<rightvol>] (currently 37.9:37.9 dB)
codec3.misc.rear1 [<leftvol>:<rightvol>] (currently 51.9:51.9 dB)
codec3.misc.center/lfe1 [<leftvol>:<rightvol>] (currently 53.9:53.9 dB)
codec3.misc.side1 [<leftvol>:<rightvol>] (currently 50.9:50.9 dB)
codec3.misc.mic [<leftvol>:<rightvol>] (currently 37.4:37.4 dB)
codec3.misc.fp-mic [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
codec3.misc.linein [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
codec3.misc.fp-headphone [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
codec3.misc.int-cd [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
codec3.misc.front [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
codec3.misc.input-mix <mic|fp-mic|linein|int-cd> (currently fp-mic)
codec3.misc.rear-mute ON|OFF (currently OFF)
codec3.misc.input-mix-mute1 ON|OFF (currently OFF)
codec3.misc.rear2 <rear|input-mix> (currently rear)
codec3.misc.center/lfe-mute ON|OFF (currently OFF)
codec3.misc.input-mix-mute2 ON|OFF (currently OFF)
codec3.misc.center/lfe2 <center/LFE|input-mix> (currently center/LFE)
codec3.misc.side-mute ON|OFF (currently OFF)
codec3.misc.input-mix-mute3 ON|OFF (currently OFF)
codec3.misc.side2 <side|input-mix> (currently side)
codec3.misc.pcm41 [<leftvol>:<rightvol>] (currently 45.9:45.9 dB)
codec3.misc.pcm4-mute ON|OFF (currently OFF)
codec3.misc.input-mix-mute4 ON|OFF (currently OFF)
codec3.misc.pcm42 <pcm4|input-mix> (currently pcm4)
codec4.jack.int-digout.mute ON|OFF (currently OFF)
vmix0-enable ON|OFF (currently ON)
vmix0-rate <decimal value> (currently 48000) (Read-only)
vmix0-channels <Stereo|Multich> (currently Stereo)
vmix0-src <Fast|High|High+|Production|OFF> (currently OFF)
vmix0-outvol <monovol> (currently 25.0 dB)
vmix0-invol <monovol> (currently 25.0 dB)
vmix0.pcm9 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm10 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm11 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm12 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)

cesium
Developer
Posts: 902
Joined: Sun Aug 12, 2007 12:51 am

Re: OSS4 O_EXCL works, but vmix does not

Postby cesium » Fri Mar 22, 2013 4:55 pm

Several notes:
A) When you run osstest, on which output sound is emitted? It could be that vmix is attached to the wrong output (the default isn't always right).
B) Try changing vmix0-channels to Stereo
C) Patch? gstreamer does usually work out of the box, if the oss4 plugin is installed (which is in recent gstreamer-good, [or] not so recent gstreamer-bad). You could have been using outdated instructions... (really old gstreamer did need a patch).

igorzwx
Known Member
Posts: 1246
Joined: Sun Jun 28, 2009 9:31 pm

Re: OSS4 O_EXCL works, but vmix does not

Postby igorzwx » Fri Mar 22, 2013 5:41 pm

cesium wrote:C) gstreamer does usually work out of the box, if the oss4 plugin is installed (which is in recent gstreamer-good, [or] not so recent gstreamer-bad). You could have been using outdated instructions... (really old gstreamer did need a patch).


Yes.
gstreamer seems to work "out of the box" with OSS4.
I tested this with the latest Mubuntu:

Code: Select all

$ sudo apt-get install gstreamer1.0-plugins-good


and everything seems to work "out of the box" with OSS4: Totem, Banshee

Could you please delete old spam from the forum?
Example: cool sneaker for sale online spam!

cy1
New Member
Posts: 2
Joined: Fri Mar 22, 2013 3:43 am

Re: OSS4 O_EXCL works, but vmix does not

Postby cy1 » Fri Mar 22, 2013 6:19 pm

OK I disabled vmix in /usr/lib/oss/osscore.conf and that allowed every application to play sound (albeit without mixing (which I don't really need)). So if you don't have any ideas what I've got will work. I still don't know how to get vmix working right though, or alternatives that might be easier to manage than gstreamer.

I have a pretty recent gstreamer, with the oss4 plugin.

Code: Select all

gst-inspect-1.0 version 1.0.5
GStreamer 1.0.5
http://www.archlinux.org/


What I need is a program that can decode various audio files (mp3,vorbis,aac,mp4,etc) where I can provide a replay-gain without embedding it in the file (the gain is in a database, and many audio files can't embed that information), whose playlist is also drawn from the database table. The player also has to indicate whether it has completely played a song, or been interrupted, so I can set a song's "last-played" value or not. Is there some way to do that besides gstreamer? It's the only general audio/media decoding/playback library I know of. I wrote a program using gstreamer to do this stuff, which has worked up until I got this new motherboard w/ new onboard sound.

I ran strace on both this player and osstest to see what device they were accessing, and both opened /dev/oss/oss_hdaudio0/pcm0. That's definitely the device for the green jack, as osstest sends audio bright and clear to the speakers. The only difference is that osstest opened it using the O_EXCL flag, which I gather is deliberately aimed at skipping vmix. Adding that flag would be the only reason I needed to patch gstreamer. But again, that would defeat the purpose of vmix entirely.

cesium
Developer
Posts: 902
Joined: Sun Aug 12, 2007 12:51 am

Re: OSS4 O_EXCL works, but vmix does not

Postby cesium » Fri Mar 22, 2013 6:51 pm

Hmm.. You can try enabling vmix but disabling vmix autoattach in osscore.conf, and than attaching vmix manually, say using '-r' and/or '-M' switches (see "man vmixctl" for details). e.g.:
vmixctl attach -r -M /dev/oss/oss_hdaudio0/pcm0

Also, please paste 'ossinfo -v3' output.

Btw, alot of people who do music stations use MPD, but I don't know if it can keep a gain per file stored somewhere...

igorzwx: oops. Will do.

igorzwx
Known Member
Posts: 1246
Joined: Sun Jun 28, 2009 9:31 pm

Re: OSS4 O_EXCL works, but vmix does not

Postby igorzwx » Fri Mar 22, 2013 7:36 pm

cy1 wrote:What I need is a program that can decode various audio files (mp3,vorbis,aac,mp4,etc)


MPlayer/Mplayer2, DeadBeef, Audacious seem to be able to play everything.

DeadBeef and Audacious permit "exclusive mode" which disables VMIX.
However, to have "exclusive mode" with DeadBeef, you have to install Petrov's plugin.

You may also try to hack Mplayer2 to enable "exclusive" mode.
See the code of ossplay and Audacious.
You may also ask Michal viewtopic.php?f=3&t=3834

igorzwx
Known Member
Posts: 1246
Joined: Sun Jun 28, 2009 9:31 pm

Re: OSS4 O_EXCL works, but vmix does not

Postby igorzwx » Fri Mar 22, 2013 8:53 pm

cesium wrote:C)gstreamer does usually work out of the box, if the oss4 plugin is installed (which is in recent gstreamer-good, [or] not so recent gstreamer-bad). You could have been using outdated instructions... (really old gstreamer did need a patch).


Although it works on Mubuntu, your advice is likely to be wrong.
To make "gstreamer" working with OSS4, you should also remove something, see the manual for Ubuntu users.

On Arch Linux, one may need to recompile a dozen of multimedia applications.

The old spam is still staying on the most obvious place (since Jan 22, 2013 3:32 am)

by cheapshoes90
Tue Jan 22, 2013 3:32 am

tarik2cyprian
Member
Posts: 28
Joined: Thu Jan 24, 2013 7:04 pm

Re: OSS4 O_EXCL works, but vmix does not

Postby tarik2cyprian » Mon Oct 14, 2013 7:34 am

It is said that jackd typically opens the device in O_EXCL mode without having to disable vmixer. I am currently using jackd2 and when I start the
jackd server it keeps getting ran through vmix.

Is there a way I can correct this issue without having to disable vimixer manually?

Thanks

tarik2cyprian


Return to “Linux”

Who is online

Users browsing this forum: No registered users and 4 guests