How to get OSS working well with sdlmame?

OSS specific Linux discussion (x86/amd64)

Moderators: hannu, dev, cesium

xenphor
New Member
Posts: 5
Joined: Sat Aug 24, 2013 12:02 am

How to get OSS working well with sdlmame?

Postby xenphor » Sat Aug 24, 2013 12:17 am

edit: Ok I guess it was a false alarm because the audio was crackling with firefox as well. I undid the changes I made in ossxmix and rebooted and now the sound is okay. The only things I changed were enabling center/rear speakers and mixer so I don't know what happened. The osstest I did sounded okay.

I still find it to be very quiet though so does anyone know how I could boost it?


I just installed oss through the AUR and it seems to work fine, although it is quite quiet. Ossxmix works and I have everything turned up to the max.

Now the problem with mame is that I get distorted/crackling sound. I have disabled alsa and everything so obviously I get a lot of errors for that. I can't get them to go away even if I change the config to use oss or set the variable SDL_AUDIODRIVER=dsp.


Code: Select all

'$ sdlmame
ALSA lib seq_hw.c:457:(snd_seq_hw_open) open /dev/snd/seq failed: No such device or address
ALSA lib confmisc.c:768:(parse_card) cannot find card '0'
ALSA lib conf.c:4248:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:4248:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib conf.c:4248:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:4727:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM default
ALSA lib confmisc.c:768:(parse_card) cannot find card '0'
ALSA lib conf.c:4248:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:4248:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib conf.c:4248:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:4727:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM default
ALSA lib confmisc.c:768:(parse_card) cannot find card '0'
ALSA lib conf.c:4248:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:4248:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib conf.c:4248:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:4727:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM default
Average speed: 100.00% (6 seconds)

If I set the variable:

Code: Select all

$ SDL_AUDIODRIVER=dsp sdlmame
ALSA lib seq_hw.c:457:(snd_seq_hw_open) open /dev/snd/seq failed: No such device or address
Average speed: 100.00% (7 seconds)


Either way I get sound but it's distorted.

Code: Select all

$ ossinfo
Version info: OSS 4.2 (b 2008/201306140444) (0x00040100) TRIAL
Platform: Linux/x86_64 3.10.7-1-ARCH #1 SMP PREEMPT Thu Aug 15 11:55:34 CEST 2013 (localhost)

Number of audio devices:        9
Number of audio engines:        13
Number of MIDI devices:         0
Number of mixer devices:        1


Device objects
 0: osscore0 OSS core services
 1: oss_hdaudio0 Intel HD Audio interrupts=19795 (19795)
    HD Audio controller Intel HD Audio
    Vendor ID    0x80861e20
    Subvendor ID 0x1043841b
     Codec  0: ALC892 (0x10ec0892/0x1043841b)
 2: oss_usb0 USB audio core services

MIDI devices (/dev/midi*)

Mixer devices
 0: High Definition Audio ALC892 (Mixer 0 of device object 1)

Audio devices
HD Audio play front               /dev/oss/oss_hdaudio0/pcm0  (device index 0)
HD Audio play rear                /dev/oss/oss_hdaudio0/pcm1  (device index 1)
HD Audio play center/LFE          /dev/oss/oss_hdaudio0/pcm2  (device index 2)
HD Audio play side                /dev/oss/oss_hdaudio0/pcm3  (device index 3)
HD Audio play pcm4                /dev/oss/oss_hdaudio0/pcm4  (device index 4)
HD Audio play spdif-out           /dev/oss/oss_hdaudio0/spdout0  (device index 5)
HD Audio play spdifout            /dev/oss/oss_hdaudio0/spdout1  (device index 6)
HD Audio rec mix                  /dev/oss/oss_hdaudio0/pcmin0  (device index 7)
HD Audio rec mix                  /dev/oss/oss_hdaudio0/pcmin1  (device index 8)

Nodes
  /dev/dsp -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_in -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_out -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_ac3 -> /dev/oss/oss_hdaudio0/spdout0
  /dev/dsp_mmap -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_multich -> /dev/oss/oss_hdaudio0/pcm0

Code: Select all

$ ossmix -a | grep -i vmix
vmix0-enable ON|OFF (currently ON)
vmix0-rate <decimal value> (currently 48000) (Read-only)
vmix0-channels <Stereo|Multich> (currently Stereo)
vmix0-src <Fast|High|OFF> (currently Fast)
vmix0-outvol <monovol> (currently 24.6 dB)
vmix0-invol <monovol> (currently 25.0 dB)
vmix0.pcm9 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB) ("plugin-containe")
vmix0.pcm10 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm11 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm12 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)

Return to “Linux”

Who is online

Users browsing this forum: No registered users and 1 guest