HD Audio Creative X-Fi XTreme: No Mic Detection

OSS specific Linux discussion (x86/amd64)

Moderators: hannu, dev, cesium

Xylemon
Member
Posts: 28
Joined: Tue Aug 19, 2014 2:53 pm
Sound Card: Creative X-Fi Xtreme
OS: Slackware Linux

HD Audio Creative X-Fi XTreme: No Mic Detection

Postby Xylemon » Thu Aug 27, 2015 8:07 pm

Hello all,

I recently moved back over to a desktop out of constant frustration with my Laptop's on-board audio quality and other problems. I had initial troubles getting my sound card working, as audio output would randomly not work. However, this issue seems to be solved since I switched the vmix channels to "Multich" instead of "Stereo". So the next thing I've been trying to conquer is getting my mic working. It's in the right jack, but no matter what settings I mess with on my mixer, I can never get the damn thing to work. I usually get an input/output error on all the mic device indexes. An interesting note is that if I check "black" or "blue" it doesn't give me an input/output error on /dev/dsp7 but I still don't get anything except a very faint loopback from my desktop audio at times. Below is my desktop specs and attached is the output of my mixer and so on.

System: Slackware Linux 64-bit with Kernel 4.1.6 and OSS 4.2 build 2011
Soundcard: Creative PCI-e Sound Blaster X-Fi XTreme
Model: SB1040EF
or as the OSS mixer likes to call it, "High Definition Audio Createive XFi XTreme" (I think someone forgot to check for typos)

Any help is appreciated,
Gethyn.
Attachments
ossmix-v3.txt
(2.96 KiB) Downloaded 467 times
ossinfo-v3.txt
(10.54 KiB) Downloaded 499 times

igorzwx
Known Member
Posts: 1258
Joined: Sun Jun 28, 2009 9:31 pm

Re: HD Audio Creative X-Fi XTreme: No Mic Detection

Postby igorzwx » Thu Aug 27, 2015 8:56 pm

It seems that you are trying to record from the default device /dev/dsp, that is, from VMIX.
However, the mic input is muted in VMIX

Code: Select all

vmix0-invu [<leftVU>:<rightVU>] (currently 0:0) (Read-only)


If you want to record "digital crap" of better quality, you may try to record from HW device, instead of VMIX.

Xylemon wrote: I usually get an input/output error on all the mic device indexes. An interesting note is that if I check "black" or "blue" it doesn't give me an input/output error on /dev/dsp7


Disable VMIX in the "conf" and reboot. The repeat the test.

Code: Select all

$ ossrecord -vl -d<devname> - | ossplay -


Post here the output of the terminal.

Xylemon
Member
Posts: 28
Joined: Tue Aug 19, 2014 2:53 pm
Sound Card: Creative X-Fi Xtreme
OS: Slackware Linux

Re: HD Audio Creative X-Fi XTreme: No Mic Detection

Postby Xylemon » Thu Aug 27, 2015 9:34 pm

igorzwx wrote:It seems that you are trying to record from the default device /dev/dsp, that is, from VMIX.
However, the mic input is muted in VMIX

Code: Select all

vmix0-invu [<leftVU>:<rightVU>] (currently 0:0) (Read-only)


If you want to record "digital crap" of better quality, you may try to record from HW device, instead of VMIX.


Thanks for the reply, I have a couple inquires; One, why is "vmix0-invu" in Read-only mode? If I were able to modify it, would I then get input audio from VMIX? Also I get the input/output errors from /dev/dsp6 through /dev/dsp8, I do get the same error from /dev/dsp obviously but I don't try that device when using ossrecord as a test. Final question is, how would I go about recording from the HW then? Turn off VMIX?

igorzwx
Known Member
Posts: 1258
Joined: Sun Jun 28, 2009 9:31 pm

Re: HD Audio Creative X-Fi XTreme: No Mic Detection

Postby igorzwx » Thu Aug 27, 2015 9:46 pm

Xylemon wrote:Thanks for the reply, I have a couple inquires; One, why is "vmix0-invu" in Read-only mode? If I were able to modify it, would I then get input audio from VMIX? Also I get the input/output errors from /dev/dsp6 through /dev/dsp8, I do get the same error from /dev/dsp obviously but I don't try that device when using ossrecord as a test. Final question is, how would I go about recording from the HW then? Turn off VMIX?


Disable VMIX in /usr/lib/oss/conf/osscore.conf
Then reboot.

Run:

Code: Select all

$ ossrecord -vl -d<devname> - | ossplay -


Post here the output of the terminal.

And this:

Code: Select all

$ ossrecord -i\?


***
Xylemon wrote:ossinfo-v3.txt
HD Audio rec linein /dev/oss/oss_hdaudio0/pcmin0 (device index 6)
Legacy device /dev/dsp6
Caps: DUPLEX TRIGGER MMAP
Modes: IN/OUT
In engine 1: 6/HD Audio rec linein
Busy (IN) label 'VMIX_IN'
Engine 2: 9/HD Audio play pcm1 (vmix)
Busy (OUT) by PID 12914 / xmms label 'xmms'
Engine 3: 10/HD Audio play pcm1 (vmix)
Busy (IN) by PID 26715 / audacity label 'audacity'
Engine 4: 11/HD Audio play pcm1 (vmix)
Busy (OUT) by PID 21556 / pidgin label 'pidgin'


Kill 'pidgin', 'audacity', 'xmms', and other crap.

Xylemon wrote:I have a couple inquires


There is a special forum for such "inquires" → _http://ubuntuforums.org

Otherwise, read "man vmixctl" and try to understand it.

Code: Select all

$ man vmixctl
   ATTACH OPTIONS
       o      -r      Disable recording functionality. By  default  vmix  will
              support recording if the master device(s) support it.


***

This is how your VMIX is attached:

Xylemon wrote:ossinfo-v3.txt
HD Audio play pcm1 (vmix) loopback record /dev/oss/oss_hdaudio0/loop0 (device index 9)
Legacy device NONE
Caps: DUPLEX BATCH TRIGGER MMAP MULTI VIRTUAL HIDDEN
Modes: IN/OUT
In engine 1: 13/HD Audio play pcm1 (vmix) loopback record
Available for use
Engine 2: 14/HD Audio play pcm1 (vmix)
Available for use


You seems to be an Ubuntu newbie. Right?
They usually make very strange experiments.
As a result, they have "very strange problems".
Then they ask many strange questions about the "esoteric nature" of those "very strange problems".

Usually, Ubuntu newbies do not report about their "strange experiments", largely because, perhaps, they hope that their "very strange problems" have nothing to do with their "strange experiments". It is a kind of "audacity of hope" _https://en.wikipedia.org/wiki/The_Audacity_of_Hope

There is a special handbook on how to deal with "very strange problems". It contains many interesting observations, for example:

When I am alone in a forest at night-time and jump from one tree to another, I often think that life is so strange.
George Mikes, How to be an Alien: A handbook for beginners and advanced pupils, 1946.
_https://en.wikipedia.org/wiki/How_to_be_an_Alien

Xylemon
Member
Posts: 28
Joined: Tue Aug 19, 2014 2:53 pm
Sound Card: Creative X-Fi Xtreme
OS: Slackware Linux

Re: HD Audio Creative X-Fi XTreme: No Mic Detection

Postby Xylemon » Thu Aug 27, 2015 11:56 pm

igorzwx wrote:
Disable VMIX in /usr/lib/oss/conf/osscore.conf
Then reboot.

Run:

Code: Select all

$ ossrecord -vl -d<devname> - | ossplay -


Post here the output of the terminal.



dsp6 to dsp8 give:

Recording wav: Speed 48000Hz 16 bits Stereo
/dev/dsp<numberhere>: Input/output error

Sound data ended prematurely!

Initially dsp6 appeared to be recording (but now it does the above):

Recording wav: Speed 48000Hz 16 bits Stereo
- [ .......] 13.00 secs VU 0

Though I'm guessing I was supposed to be hearing my mic right? Because I heard nothing.

igorzwx wrote:
And this:

Code: Select all

$ ossrecord -i\?




Possible recording sources for the selected device:

(currently selected)

igorzwx wrote:
Xylemon wrote:I have a couple inquires


There is a special forum for such "inquires" → _http://ubuntuforums.org



Very humorous! Even a simple RTFM would've been more appropriate.

igorzwx wrote:You seems to be an Ubuntu newbie. Right?
They usually make very strange experiments.
As a result, they have "very strange problems".
Then they ask many strange questions about the "esoteric nature" of those "very strange problems".


Erm no, I would just say an OSS newbie. That is simply me messing around with the loopback setting in osscore.conf and not investigating it any further. I don't believe it's had any affect on the mic not working however I'm sure there's no harm in turning it back off.

igorzwx
Known Member
Posts: 1258
Joined: Sun Jun 28, 2009 9:31 pm

Re: HD Audio Creative X-Fi XTreme: No Mic Detection

Postby igorzwx » Fri Aug 28, 2015 12:05 am

Xylemon wrote:That is simply me messing around with the loopback setting in osscore.conf and not investigating it any further. I don't believe it's had any affect on the mic not working.


Perhaps, more precisely, you firmly believe that your "strange experiments" have nothing to do with your "very strange problems".
It is a kind of "audacity of faith".
It is your "gift of faith" that prevents you from understanding the OSS4 manuals.

Xylemon
Member
Posts: 28
Joined: Tue Aug 19, 2014 2:53 pm
Sound Card: Creative X-Fi Xtreme
OS: Slackware Linux

Re: HD Audio Creative X-Fi XTreme: No Mic Detection

Postby Xylemon » Fri Aug 28, 2015 12:57 am

igorzwx wrote:Perhaps, more precisely, you firmly believe that your "strange experiments" have nothing to do with your "very strange problems".
It is a kind of "audacity of faith".
It is your "gift of faith" that prevents you from understanding the OSS4 manuals.


If you don't want to help, and would rather continue to insult me and try to analyze me, then simply don't post. I've even reverted my very "strange experiments" and I'm still having the same exact problem. I figured it wasn't the cause since the loopback setting on my laptop had no affect on my mic there.

igorzwx
Known Member
Posts: 1258
Joined: Sun Jun 28, 2009 9:31 pm

Re: HD Audio Creative X-Fi XTreme: No Mic Detection

Postby igorzwx » Fri Aug 28, 2015 1:10 am

Xylemon wrote:If you don't want to help, and would rather continue to insult me and try to analyze me, then simply don't post. I've even reverted my very "strange experiments" and I'm still having the same exact problem. I figured it wasn't the cause since the loopback setting on my laptop had no affect on my mic there.


If you reverted something, you have to post your new "ossmix", otherwise, it might be difficult to help.

Xylemon wrote:ossmix-v3.txt

Code: Select all

jack.fp-pink ON|OFF (currently OFF)


Do you know what "pink" means in this context?

Xylemon
Member
Posts: 28
Joined: Tue Aug 19, 2014 2:53 pm
Sound Card: Creative X-Fi Xtreme
OS: Slackware Linux

Re: HD Audio Creative X-Fi XTreme: No Mic Detection

Postby Xylemon » Fri Aug 28, 2015 1:21 am

igorzwx wrote:If you reverted something, you have to post your new "ossmix", otherwise, it might be difficult to help.

I have attached a new text that shows both outputs of ossmix and ossinfo. I have pretty much reverted any change in the osscore config, so that means vmix is back on (I did have another test with it off and loopback reverted, and my mic was still not working). I can turn it back off if desired.

igorzwx wrote:
Xylemon wrote:ossmix-v3.txt

Code: Select all

jack.fp-pink ON|OFF (currently OFF)


Do you know what "pink" means in this context?


I'm afraid I don't. Only thing I could guess is it's related to one of my jacks on the card. I've turned it on before and didn't notice a difference.
Attachments
ossinfo_and_ossmix.txt
(12.16 KiB) Downloaded 474 times

igorzwx
Known Member
Posts: 1258
Joined: Sun Jun 28, 2009 9:31 pm

Re: HD Audio Creative X-Fi XTreme: No Mic Detection

Postby igorzwx » Fri Aug 28, 2015 1:43 am

Xylemon wrote:I'm afraid I don't. Only thing I could guess is it's related to one of my jacks on the card.


Code: Select all

$ man oss_hdaudio
       Some motherboards may not correctly initialize the jacks  according  to
       their  color  and functionality but in general here's the configuration
       that should generally be followed:

              o Orange = Center/LFE
                     o Blue = Line-in

              o Black = Rear
                     o Green = Front

              o Grey = Side
                     o Pink = Mic

       Some Azalia codecs support front panel connectors and so if you see fp-
       green  and  fp-pink  connectors, then these are for front panel speaker
       and mic/line-in Jacks.

Xylemon
Member
Posts: 28
Joined: Tue Aug 19, 2014 2:53 pm
Sound Card: Creative X-Fi Xtreme
OS: Slackware Linux

Re: HD Audio Creative X-Fi XTreme: No Mic Detection

Postby Xylemon » Fri Aug 28, 2015 2:40 am

Ok, but I've turned on both jack.blue and jack.fp-pink separately and at the same time, turned up the volume on record.linein and record.fp-mic, and kept trying "ossrecord -vl -d /dev/oss/oss_hdaudio0/pcmin1 - | ossplay -" and along with pcmin0 and I would hear noise but still no input from the mic itself. I do not have a red jack on my soundcard, just a blue one which according to the box is indeed the mic jack. Now at what seems random, jack.fp-pink and jack.blue won't turn on, even if I keep going "ossmix jack.fp-pink on" as soon as I do "ossmix jack.fp-pink" it just reports that it's still off. Could it be that the drivers for my card need some work?

igorzwx
Known Member
Posts: 1258
Joined: Sun Jun 28, 2009 9:31 pm

Re: HD Audio Creative X-Fi XTreme: No Mic Detection

Postby igorzwx » Fri Aug 28, 2015 2:59 am

Xylemon wrote:Ok, but I've turned on both jack.blue and jack.fp-pink separately and at the same time, turned up the volume on record.linein and record.fp-mic, and kept trying "ossrecord -vl -d /dev/oss/oss_hdaudio0/pcmin1 - | ossplay -" and along with pcmin0 and I would hear noise but still no input from the mic itself. I do not have a red jack on my soundcard, just a blue one which according to the box is indeed the mic jack. Now at what seems random, jack.fp-pink and jack.blue won't turn on, even if I keep going "ossmix jack.fp-pink on" as soon as I do "ossmix jack.fp-pink" it just reports that it's still off. Could it be that the drivers for my card need some work?


To simplify the problem, you may try to disable the crappy VMIX.

Then, you should test everything carefully.

If it does not help, you may try to enable "hidden jacks". They might be disconnected (useless), or misidentified.

* * *

Code: Select all

$ man vmixctl
DETACHING VMIX FROM AN AUDIO DEVICE
       It is not possible to detach and (re)attach vmix  to  the  same  device
       more  than  few times.


This means that the behaviour of the crappy VMIX depends on the history of your experiments.
This is a normal behaviour of buggy software.

To get rid of "very strange problems" caused by your "strange experiments", you may need to erase this history.
This means complete de-installation of OSS4 and removal of /usr/lib/oss
Then, you may try a new clean install of OSS4.


Return to “Linux”

Who is online

Users browsing this forum: No registered users and 3 guests