OSS-v4.2-build2019 fail to compile on Linux >5.4

OSS specific Linux discussion (x86/amd64)

Moderators: hannu, dev, cesium

seawright
Known Member
Posts: 109
Joined: Sat Jan 06, 2007 9:10 pm
Location: Hampshire UK

OSS-v4.2-build2019 fail to compile on Linux >5.4

Postby seawright » Fri Aug 21, 2020 7:31 pm

Linux modules for OSS-v4.2-build2019 fails to compile on Linux version 5.4 and later.
Anyone requiring OSS-v4.2 for recent Linux kernels should compile from source available from the Open Sound System git repository at:
https://sourceforge.net/p/opensound/git/ci/master/tree/
which was last updated on 2020-07-20.
regards
Clive

danjp
Member
Posts: 14
Joined: Thu Aug 09, 2012 12:36 pm

Re: OSS-v4.2-build2019 fail to compile on Linux >5.4

Postby danjp » Tue Sep 01, 2020 7:04 pm

The patch provided in:

viewtopic.php?f=3&t=5882

also works for building the compiled version for those of us who need to Lynx 2 module.


Return to “Linux”

Who is online

Users browsing this forum: Google [Bot] and 6 guests