oss-solaris-v4.0-1002-i386 crash kernel solaris Nevada b56

OSS specific Solaris discussion (x86/SPARC)

Moderators: hannu, dev, cesium

solaris_user
Member
Posts: 15
Joined: Sun Jun 11, 2006 6:23 pm

oss-solaris-v4.0-1002-i386 crash kernel solaris Nevada b56

Postby solaris_user » Mon May 28, 2007 1:13 pm

hello,
Has someone got this problem?

May 28 14:56:52 yakari ^Mpanic[cpu0]/thread=d476a000:
May 28 14:56:52 yakari genunix: [ID 683410 kern.notice] BAD TRAP: type=7 (#nm De
vice not available) rp=d4810670 addr=0
May 28 14:56:52 yakari unix: [ID 100000 kern.notice]
May 28 14:56:52 yakari unix: [ID 839527 kern.notice] audioctl:
May 28 14:56:52 yakari unix: [ID 753105 kern.notice] #nm Device not available
May 28 14:56:52 yakari unix: [ID 243837 kern.notice] pid=1226, pc=0xfa2b83d1, sp
=0xd48106f0, eflags=0x10293
May 28 14:56:52 yakari unix: [ID 211416 kern.notice] cr0: 80050039<pg,wp,ne,et,t
s,pe> cr4: 698<xmme,fxsr,pge,pse,de>
May 28 14:56:52 yakari unix: [ID 936844 kern.notice] cr2: d2738a83 cr3: 125a8000
May 28 14:56:52 yakari unix: [ID 537610 kern.notice] gs: d47601b0 fs:
0 es: d4810160 ds: fe820160
May 28 14:56:52 yakari unix: [ID 537610 kern.notice] edi: 204000 esi: d4810
730 ebp: d48106e8 esp: d48106a8
May 28 14:56:52 yakari unix: [ID 537610 kern.notice] ebx: d5adec60 edx:
0 ecx: 2 eax: d5adec60
May 28 14:56:52 yakari unix: [ID 537610 kern.notice] trp: 7 err:
0 eip: fa2b83d1 cs: 158
May 28 14:56:52 yakari unix: [ID 717149 kern.notice] efl: 10293 usp: d4810
6f0 ss: 0
May 28 14:56:52 yakari unix: [ID 100000 kern.notice]

i can send more information, or core if needed

thanks in advance,

gerard

dev
Developer
Posts: 581
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA
Contact:

Postby dev » Wed May 30, 2007 4:12 am

What does ossinfo show?



regards
Dev

solaris_user
Member
Posts: 15
Joined: Sun Jun 11, 2006 6:23 pm

oss-solaris-v4.0-1002-i386 crash kernel solaris Nevada b56

Postby solaris_user » Fri Jun 08, 2007 4:46 am

dev wrote:What does ossinfo show?



regards
Dev


yakari-henry% ossinfo
Version info: OSS 4.0 (build 1002/200704100916) (0x00040002)
Platform: SunOS/i86pc 5.11 snv_56

Number of audio devices: 1
Number of audio engines: 6
Number of MIDI devices: 0
Number of mixer devices: 1


Device objects
0: ich0 Intel ICH4 (24C5)
1: sadasupport0 SADA compatibility layer
2: oss0 OSS core services
3: ossusb0 USB audio/MIDI device
4: vmix0 OSS transparent virtual support

MIDI devices (/dev/midi*)

Mixer devices (/dev/mixer*)
0: ICH AC97 Mixer (STAC9750) (Mixer 0 of device object 0)

Audio devices
/dev/oss/ich0/pcm0 Intel ICH4 (24C5) (device index 0)

dev
Developer
Posts: 581
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA
Contact:

Postby dev » Fri Jun 08, 2007 5:58 am

What application from SADA were you running at the time of the crash?
It seems that the device wasn't available - I wonder if you can run osstest under command line mode and ensure that all audio tests produce proper sound.



Regards
Dev Mazumdar


Return to “Solaris”

Who is online

Users browsing this forum: Bing [Bot] and 1 guest