OSS for Sigmatel STAC9271D codec on intelDP35DP

OSS specific Solaris discussion (x86/SPARC)

Moderators: hannu, dev, cesium

New Member
Posts: 1
Joined: Sat May 17, 2008 6:49 am

OSS for Sigmatel STAC9271D codec on intelDP35DP

Postby theemperor » Sat May 17, 2008 7:36 am


I have tried installing OSS 1015 on my solaris 10 Express Developer edition.

I have Sigmatel STAC9271D codec in Intel ICH9 family Controller.

Result shows like this

# pkgadd -d oss-solaris-v4.0-1015-i386.pkg | all
all: not found
The following packages are available:
1 oss Open Sound System
(i386) v4.0-1015

Select package(s) you wish to process (or 'all' to process
all packages). (default: all) [?,??,q]:

Processing package instance <oss> from </Documents>

Open Sound System(i386) v4.0-1015
WARNING: Stale lock installed for pkgadd, pkg oss quit in install state.
Removing lock.

This appears to be an attempt to install the same architecture and version of a package which is already installed. This installation will attempt to overwrite this package.

The installation of this package was previously terminated and installation was never successfully completed.

Do you want tocontinue with the installation of <oss> [y,n,?] y
Using </> as the package base directory.
##Processing package information.
##Processing system information.
157 package pathnames are already properly installed.
##Verifying disk space requirements.
##Checking for conflicts with packages already installed.
##Checking for setuid/setgid programs.

This package contains scripts which will be executed with super-user
permission during the process of installing this package.

Do you want to continue with the installation of <oss> [y,n,?] y

Installing Open Sound System as <oss>

##Installing part 1 of 1
[ verifying class <none> ]


For long time no process happened after this.

I tried "osstest" and "ossinfo"

The result was

# osstest
/dev/mixer: no such file or directory
The device file is missing rom /dev.
Perhaps you have not installed and started Open Sound System yet

No /dev/mixer device available in your system.
Perhaps Open Sound System is not installed or running.

How do i find out the OSS is installed in machine properly or not.

Thanks in Advance


Return to “Solaris”

Who is online

Users browsing this forum: No registered users and 1 guest