No sound since today

OSS specific Solaris discussion (x86/SPARC)

Moderators: hannu, dev, cesium

New Member
Posts: 2
Joined: Fri Dec 12, 2008 6:10 pm

No sound since today

Postby Can0n » Fri Dec 12, 2008 6:17 pm

I installed OpenSolaris 2 days ago and getting familiar with it as we speak. The first thing I fixed was the sound since it didn't work out-of-the-box, just grabbed the OSS-package (oss-solaris-v4.0-1016-i386.pkg) and did a pkgadd -d pkgname. This worked wonderful, the sound worked right away and I could play music and all that. It also worked fine yesterday, everything worked as it would.

But.. When I booted my computer today it didn't work at all, it says that it's working. The sound-icon on the gnome-panel is there and I can lower/higher/mute the volume. When I play something in Songbird it doesn't give any error of any kind, same in Rhythmbox.
I have tried to reinstalled the driver and rebooted the computer in several different ways but it doesn't work.
Here is my outputs from ossinfo and osstest:

And I've also looked in /var/adm/messages and there is nothing there with audio or sound in it.

Any ideas what I can try?


OKey, so the sound works with an older boot enviroment. Although, some of the programs that I have installed after doesn't, duh.
Will this help?

OKey, so it works now on my newest BE. All I did was uninstall OSS in the new BE, rebooted into the old one, heard that the sound worked, rebooted into the new BE and reinstalled OSS and it worked.
It's so amazing that it just works. *sarcasm*

New Member
Posts: 2
Joined: Fri Dec 12, 2008 6:10 pm

Postby Can0n » Sun Dec 14, 2008 2:27 pm

So. THe problem is back. When I booted my computer today I had sound, osstest worked fine. Now, with no reboot or anything, the sound is gone.
This is REALLY strange AND annoying!

P L E A S E help

Posts: 585
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA

Postby dev » Mon Dec 15, 2008 6:49 pm


Grab the OSS 4.1rc4 packages from ... 4-i386.pkg

You should uninstall the 4.0 version by typing pkgrm OSS and rebooting the system and then install the OSS 4.1 since there are some device naming changes between the two versions.


Return to “Solaris”

Who is online

Users browsing this forum: No registered users and 3 guests