Couldn't open mixer device /dev/audioctl

OSS specific Solaris discussion (x86/SPARC)

Moderators: hannu, dev, cesium

New Member
Posts: 1
Joined: Thu Sep 24, 2009 6:51 pm

Couldn't open mixer device /dev/audioctl

Postby tendigitz » Thu Sep 24, 2009 6:58 pm

Code: Select all

Version info: OSS 4.2 (b 2000/200909100851) (0x00040100)
Platform: SunOS/i86pc 5.10 Generic_139556-08 (unknown)

Number of audio devices:        1
Number of audio engines:        6
Number of MIDI devices:         0
Number of mixer devices:        1

Device objects
 0: oss_ich0 Intel ICH (2415) interrupts=118 (236)
 1: osscore0 OSS common devices
 2: oss_sadasupport SADA compatibility layer

MIDI devices (/dev/midi*)

Mixer devices
 0: ICH AC97 Mixer (STAC9700) (Mixer 0 of device object 0)

Audio devices
Intel ICH (2415)                  /dev/oss/oss_ich0/pcm0  (device index 0)

  /dev/dsp -> /dev/oss/oss_ich0/pcm0
  /dev/dsp_in -> /dev/oss/oss_ich0/pcm0
  /dev/dsp_out -> /dev/oss/oss_ich0/pcm0
  /dev/dsp_ac3 -> /dev/oss/oss_ich0/pcm0
  /dev/dsp_multich -> /dev/oss/oss_ich0/pcm0
  /dev/mixer -> ../devices/pseudo/osscore@0:mixer
  /dev/sndstat -> ../devices/pseudo/osscore@0:sndstat

Hey can you please help? The audio icon in task bar of Solaris 10 is strike out.
But osstest command plays the sound fine.
Please give me the commands to fix this
Thanks a lot

New Member
Posts: 2
Joined: Mon Jan 05, 2009 11:54 am
Location: Sweden

Re: Couldn't open mixer device /dev/audioctl

Postby takahidehimself » Wed Sep 30, 2009 7:42 am

Are the oss_sadasupport devices properly setup?

Code: Select all

ls -l /devices/pseudo/oss_sadasupport\@0\:sound\,audio*

They should have the file mode bits set to 0666.

New Member
Posts: 1
Joined: Sun Nov 15, 2009 10:08 am

Re: Couldn't open mixer device /dev/audioctl

Postby drmark » Sun Nov 15, 2009 10:15 am

I followed the suggestion for setting the file permissions:

$ chmod 666 /devices/pseudo/oss_sadasupport\@0\:sound\,audio*

That solved my problem. Before doing that, ´osstest´ worked but the sound was out for
non-OSS programs, like rhythmbox. The sound is back now.


Return to “Solaris”

Who is online

Users browsing this forum: No registered users and 2 guests