Page 1 of 1

NOOB - Install OSS MacbookPro/FreeBSD

Posted: Mon Mar 19, 2007 8:03 pm
by rscow
I'm trying to get sound working on my MacbookPro, using FreeBSD 6.2 as a VM in Parallels. I don't see a sound card when I cat /dev/sndstat. So, I figured I'd try to install OSS v4.0.

I have d/l'd the .tbz, and tar'd it. It is in /tmp.

ls /tmp reveals:

ls
+COMMENT .font-unix
+CONTENTS .gdm_socket
+DEINSTALL .snap
+DESC etc
+POST-DEINSTALL fam-roger
+POST-INSTALL fam-root
.ICE-unix oss-freebsd-v4.0-1000-i386.tbz
.X0-lock ssh-kUM0IUHWq8
.X11-unix usr
.XIM-unix

this leaves me with separate files, but no .pkg to install via pkg_add, per the instructions in "oss-install.pdf".

So, will installing OSS get me closer to having sound? And if so, where do I go from here?

Thanks.

Roger

Re: NOOB - Install OSS MacbookPro/FreeBSD

Posted: Mon Mar 19, 2007 9:18 pm
by dev
rscow wrote:I'm trying to get sound working on my MacbookPro, using FreeBSD 6.2 as a VM in Parallels. I don't see a sound card when I cat /dev/sndstat. So, I figured I'd try to install OSS v4.0.

I have d/l'd the .tbz, and tar'd it. It is in /tmp.

ls /tmp reveals:

ls
+COMMENT .font-unix
+CONTENTS .gdm_socket
+DEINSTALL .snap
+DESC etc
+POST-DEINSTALL fam-roger
+POST-INSTALL fam-root
.ICE-unix oss-freebsd-v4.0-1000-i386.tbz
.X0-lock ssh-kUM0IUHWq8
.X11-unix usr
.XIM-unix

this leaves me with separate files, but no .pkg to install via pkg_add, per the instructions in "oss-install.pdf".

So, will installing OSS get me closer to having sound? And if so, where do I go from here?

Thanks.

Roger


You are supposed to run pkg_add oss-freebsd*.tbz - do not extract it!.


regards
Dev

That worked

Posted: Mon Mar 19, 2007 10:24 pm
by rscow
Dev, that worked. I didn't know you could pkg_add a tarball that wasnt extracted.

I do draw your attention to the install instructions .pdf that you download from the OSS site along with the tarball. It refers to a .pkg.

Anyway, osstest ran after a reboot, and all is well with my sound.

Thanks very much

Roger

Re: That worked

Posted: Mon Mar 19, 2007 11:39 pm
by dev
rscow wrote:Dev, that worked. I didn't know you could pkg_add a tarball that wasnt extracted.

I do draw your attention to the install instructions .pdf that you download from the OSS site along with the tarball. It refers to a .pkg.

Anyway, osstest ran after a reboot, and all is well with my sound.

Thanks very much

Roger


Ah ok thanks, we'll fix that up.




regards
Dev Mazumdar

Re: NOOB - Install OSS MacbookPro/FreeBSD

Posted: Tue Mar 20, 2007 6:05 pm
by dev
rscow wrote:I'm trying to get sound working on my MacbookPro, using FreeBSD 6.2 as a VM in Parallels. I don't see a sound card when I cat /dev/sndstat. So, I figured I'd try to install OSS v4.0.

I have d/l'd the .tbz, and tar'd it. It is in /tmp.

ls /tmp reveals:

ls
+COMMENT .font-unix
+CONTENTS .gdm_socket
+DEINSTALL .snap
+DESC etc
+POST-DEINSTALL fam-roger
+POST-INSTALL fam-root
.ICE-unix oss-freebsd-v4.0-1000-i386.tbz
.X0-lock ssh-kUM0IUHWq8
.X11-unix usr
.XIM-unix

this leaves me with separate files, but no .pkg to install via pkg_add, per the instructions in "oss-install.pdf".

So, will installing OSS get me closer to having sound? And if so, where do I go from here?

Thanks.

Roger



Hi,


If you're going through Parallels, its likely you're not getting the same HDAudio device as your MacBook. I wonder what kind of device is being emulated by parallels. In VmWare, they emulate the ES1371 SB PCI128. In Qemu they emulate both ES1371 and SB16 ISA. It's unlikely that parallels can emulate a HDaudio device.


regards
Dev Mazumdar