no digital audio, only midi

OSS specific BSD discussion (FreeBSD/NetBSD/OpenBSD)

Moderators: hannu, dev, cesium

New Member
Posts: 9
Joined: Sat Aug 14, 2004 2:16 pm

no digital audio, only midi

Postby fred » Sun Jan 23, 2005 1:48 am

I can play wavetable MIDI just fine using ossmplay, but don't get any sound from digital audio. I tried using ossplay on a wav file which proceeds with no errors and will eventually complete, but there is no sound. I tried -d/dev/dsp0 and -d/dev/dsp1. Also, the test built into the OSS install completes with no errors, but doesn't give any sound. The speaker volume is fine because I can hear the wavetable MIDI. The ossxmixer levels are near maximum.

MediaTrix AudioTrix 3D-XG

I did a fresh install of FreeBSD 5.3 and have updated to 5.3-RELEASE-p5-SMP. The problem has been the same since I installed FreeBSD 5.3 and OSS. I only installed the basic OSS drivers so far and have not installed any extra modules (pro mixer).

This sound card has a hardware design feature such that it boots up with the two channels for digital audio assigned to MIDI, so digital audio would be silent. The OSS drivers worked fine in FreeBSD 4.x for both MIDI and digital audio.

Thanks for any suggestions.

Return to “BSD”

Who is online

Users browsing this forum: No registered users and 1 guest