Problems with ATI AC'97 sound card

OSS specific BSD discussion (FreeBSD/NetBSD/OpenBSD)

Moderators: hannu, dev, cesium

abzn
New Member
Posts: 2
Joined: Fri Jul 08, 2005 6:30 pm

Problems with ATI AC'97 sound card

Postby abzn » Fri Jul 08, 2005 6:37 pm

after some time of listening music, or KDE sound effects pop's error message:
Sound server fatal error:
AudioSubSystem::handleIO: write failed
len = -1, can_write = 3768, errno = 35 (Resource temporarily unavailable)
This might be a sound hardware/driver specific problem (see aRts FAQ)

I use ATI AC 97 sound card, FreeBSD 5.4, latest version oss

dev
Developer
Posts: 581
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA
Contact:

Re: Problems with ATI AC'97 sound card

Postby dev » Fri Jul 08, 2005 10:39 pm

abzn wrote:after some time of listening music, or KDE sound effects pop's error message:
Sound server fatal error:
AudioSubSystem::handleIO: write failed
len = -1, can_write = 3768, errno = 35 (Resource temporarily unavailable)
This might be a sound hardware/driver specific problem (see aRts FAQ)

I use ATI AC 97 sound card, FreeBSD 5.4, latest version oss



Does XMMS play MP3s or Ogg files correctly?.

Does mplayer or mpg123 or Audacity or any other audio app work correctly?



regards
Dev mazumdar

abzn
New Member
Posts: 2
Joined: Fri Jul 08, 2005 6:30 pm

Postby abzn » Sat Jul 09, 2005 5:10 am

XMMS play MP3 files correctly, and then again pop error message.
Some variant of error message
len = 944, can_write = 3768, errno = 17 (File exists)
len = 472, can_write = 3768, errno = 4 (Interrupted system call)


And one more question: why i can't use in same time more then one player, for example XMMS wrote that device is busy (can't open audio, Check please, that: Sound card tuned correctly, Other programms do not block sound card)) when KDE's arts is working, and when XMMS is working, arts don't work?

Thank you!

dev
Developer
Posts: 581
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA
Contact:

Postby dev » Mon Jul 11, 2005 4:11 am

abzn wrote:XMMS play MP3 files correctly, and then again pop error message.
Some variant of error message
len = 944, can_write = 3768, errno = 17 (File exists)
len = 472, can_write = 3768, errno = 4 (Interrupted system call)


And one more question: why i can't use in same time more then one player, for example XMMS wrote that device is busy (can't open audio, Check please, that: Sound card tuned correctly, Other programms do not block sound card)) when KDE's arts is working, and when XMMS is working, arts don't work?

Thank you!


If you configure the /dev/dsp2 device (virtual mxier) device then you can use multiple audio apps. Right now automatic forwarding of audio to an idle /dev/dspXX is not supported in FreeBSD - it works in Solaris and Linux .



best regards
Dev Mauzmdar


Return to “BSD”

Who is online

Users browsing this forum: No registered users and 0 guests