AMD SB700 ALC888 ossrecord not working

OSS related discussion in general (i.e. not limited to Linux/Solaris/BSD)

Moderators: hannu, dev, cesium

tearring
New Member
Posts: 8
Joined: Mon Jul 31, 2017 5:57 am
Sound Card: ATI SB700
OS: Linux

AMD SB700 ALC888 ossrecord not working

Postby tearring » Thu Mar 22, 2018 3:52 pm

I have an board, the chip is AMD SB700 with the ALC888 codec

Firstly, under linux with alsa driver, the command "arecord -f cd x.wav" can work.
I can record by mic which inserted into the green jack on the audio connector.

Now, i replaced the alsa with oss, then ossplay, osstest can play well.
But command "ossrecord -l -t 20 /home.x.wav" cannot work at all.

I test all the jacks (pink, blue, green) on the audio connectors,
But the VU level hold on this status VU -------++ forever, which doesn't change anymore.

I think if the mic work ,the VU level should change from 0 to -------++

Here's the ossmix -v2 info

Please help me how to configure the mixer??

Selected mixer 0/High Definition Audio ALC888
Known controls are:
jack.green.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.green [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.green.mute ON|OFF (currently OFF)
jack.black.mode <front|rear|center/LFE|side|pcm4|input> (currently rear)
jack.black [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.black.mute ON|OFF (currently OFF)
jack.orange.mode <front|rear|center/LFE|side|pcm4|input> (currently center/LFE)
jack.orange [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.orange.mute ON|OFF (currently OFF)
jack.gray.mode <front|rear|center/LFE|side|pcm4|input> (currently side)
jack.gray [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.gray.mute ON|OFF (currently OFF)
jack.pink.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.pink [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.pink.mute ON|OFF (currently OFF)
jack.fp-pink.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.fp-pink [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.fp-pink.mute ON|OFF (currently OFF)
jack.blue.mode <front|rear|center/LFE|side|pcm4|input> (currently input)
jack.blue [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.blue.mute ON|OFF (currently OFF)
jack.fp-green.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.fp-green [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.fp-green.mute ON|OFF (currently OFF)
record.mix.mute.mic1 ON|OFF (currently OFF)
record.mix.mute.fp-mic1 ON|OFF (currently OFF)
record.mix.mute.linein1 ON|OFF (currently OFF)
record.mix.mute.fp-headphone1 ON|OFF (currently OFF)
record.mix.mute.int-cd1 ON|OFF (currently OFF)
record.mix.mute.lineout1 ON|OFF (currently OFF)
record.mix.mute.green1 ON|OFF (currently OFF)
record.mix.mute.black1 ON|OFF (currently OFF)
record.mix.mute.orange1 ON|OFF (currently OFF)
record.mix.mute.gray1 ON|OFF (currently OFF)
record.mix.mute.input-mix1 ON|OFF (currently OFF)
record.mix1 [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
record.mix.mute.mic2 ON|OFF (currently OFF)
record.mix.mute.fp-mic2 ON|OFF (currently OFF)
record.mix.mute.linein2 ON|OFF (currently OFF)
record.mix.mute.fp-headphone2 ON|OFF (currently OFF)
record.mix.mute.int-cd2 ON|OFF (currently OFF)
record.mix.mute.lineout2 ON|OFF (currently OFF)
record.mix.mute.green2 ON|OFF (currently OFF)
record.mix.mute.black2 ON|OFF (currently OFF)
record.mix.mute.orange2 ON|OFF (currently OFF)
record.mix.mute.gray2 ON|OFF (currently OFF)
record.mix.mute.input-mix2 ON|OFF (currently OFF)
record.mix2 [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.mic [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.fp-mic [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.linein [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.fp-headphone [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.int-cd [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.lineout [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.green [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.black [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.orange [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.gray [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.input-mix <mic|fp-mic|linein|int-cd> (currently mic)
misc.front-mute ON|OFF (currently OFF)
misc.input-mix-mute1 ON|OFF (currently OFF)
misc.front1 [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.front2 <front|input-mix> (currently front)
misc.rear-mute ON|OFF (currently OFF)
misc.input-mix-mute2 ON|OFF (currently OFF)
misc.rear1 [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.rear2 <rear|input-mix> (currently rear)
misc.center/lfe-mute ON|OFF (currently OFF)
misc.input-mix-mute3 ON|OFF (currently OFF)
misc.center/lfe1 [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.center/lfe2 <center/LFE|input-mix> (currently center/LFE)
misc.side-mute ON|OFF (currently OFF)
misc.input-mix-mute4 ON|OFF (currently OFF)
misc.side1 [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.side2 <side|input-mix> (currently side)
misc.pcm4-mute ON|OFF (currently OFF)
misc.input-mix-mute5 ON|OFF (currently OFF)
misc.pcm41 [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.pcm42 <pcm4|input-mix> (currently pcm4)
vmix0-enable ON|OFF (currently ON)
vmix0-rate <decimal value> (currently 48000) (Read-only)
Sample rate currently used by virtual mixer on this device.
Use vmixctl(1) command to change the rate
vmix0-channels <Stereo|Multich> (currently Stereo)
vmix0-src <High|OFF> (currently Fast)
Sample rate conversion quality used by the virtual mixer.

Virtual mixer uses internally a fixed sampling rate that can be set
using the 'vmixctl rate' command (usually 48 kHz by default). Applications
that want to use different rates will be handled by performing automatic
sample rate conversions (SRC) in software. This operation will consume
some additional CPU time depending on the quality. The following
alternatives are availabe:

Fast: Use fast linear interpolation algorithm (low quality).
Low: Use slightly better linear interpolation
Medium: Use an algorithm that provides good quality with moderate CPU load.
High/High+/Production: Higher quality algorithms that consume more CPU resources.
OFF: No sample rate conversions. Sample rate locked to the master rate.

'Fast' will work best in most cases. Only users with high end audio
cards and speakers should use the other settings.
vmix0-outvol <monovol> (currently 24.7 dB)
vmix0-outvu [<leftVU>:<rightVU>] (currently 0:0) (Read-only)
vmix0-invol <monovol> (currently 25.0 dB)
vmix0-invu [<leftVU>:<rightVU>] (currently 0:0) (Read-only)
vmix0.pcm9 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix01 [<leftVU>:<rightVU>] (currently 0:0) (Read-only)
vmix0.pcm10 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix02 [<leftVU>:<rightVU>] (currently 0:0) (Read-only)
vmix0.pcm11 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix03 [<leftVU>:<rightVU>] (currently 0:0) (Read-only)
vmix0.pcm12 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix04 [<leftVU>:<rightVU>] (currently 0:0) (Read-only)

seawright
Known Member
Posts: 102
Joined: Sat Jan 06, 2007 9:10 pm
Location: Hampshire UK

Re: AMD SB700 ALC888 ossrecord not working

Postby seawright » Mon Mar 26, 2018 12:37 pm

As your microphone works with Alsa when plugged into the green jack I would suggest changing the green jack mode from front to input using:
ossmix jack.green.mode input
You may also find that ossxmix is easier to use when experimenting with the various mixer controls.
regards
Clive

tearring
New Member
Posts: 8
Joined: Mon Jul 31, 2017 5:57 am
Sound Card: ATI SB700
OS: Linux

Re: AMD SB700 ALC888 ossrecord not working

Postby tearring » Mon Apr 02, 2018 6:38 am

Actually, my CPU arch is MIPS
I did not succeed in compiling OSS V4.2 on Linux system of MIPS arch, the following link is what i asked before:
viewtopic.php?f=16&t=5849

At the moment, i ported it to VxWorks RTOS
I can make clear the following things:
1. The Audio Connector of Blue on my board is actually correspond to jack.green
2. ossmix jack.green.mode front , that i can hear the audio from headphone which plugged into the blue jack

So, it should be the green on the audio connector is correspond to jack.blue mixer ctrl.
But the default mode of Jack.blue.mode is just input mode!!!
And when i execute ossrecord, i can't record any sound. The VU meter level is hold on "--------+" status.

By the way ,i enabled virtual mixer

Who can help me , I cannot use ossxmix to help adjusting every mixer value -_- T_T

tearring
New Member
Posts: 8
Joined: Mon Jul 31, 2017 5:57 am
Sound Card: ATI SB700
OS: Linux

Re: AMD SB700 ALC888 ossrecord not working

Postby tearring » Wed Apr 04, 2018 1:03 pm

And is there any oss mixer base on Qt gui ???


Return to “General Discussion”

Who is online

Users browsing this forum: No registered users and 2 guests