Intel HDA on Acer 1641 laptop: IRQ not set (255)

OSS specific BSD discussion (FreeBSD/NetBSD/OpenBSD)

Moderators: hannu, dev, cesium


Intel HDA on Acer 1641 laptop: IRQ not set (255)

Postby maxime » Tue Jan 31, 2006 9:11 am


I'm trying to use OSS on an Acer Aspire 1641 laptop. The HDA controller seems to be recognized, but when I run soundon I get the following error:

Code: Select all

OSS HDA: IRQ not set (255). Can't continue

I tried to fiddle with the pnp_preserve and pnp_reset options with no luck.
The whole soundon.log as well as output from lspci etc. is here

Any idea ?

Posts: 585
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA

Postby dev » Wed Feb 01, 2006 6:41 pm


your pciconf is showing:
pci bus 0x0000 cardnum 0x1b function 0x00: vendor 0x8086 device 0x2668
Intel Corp. Device unknown
CardVendor 0x1025 card 0x008f (Card unknown)
STATUS 0x0010 COMMAND 0x0006
CLASS 0x04 0x03 0x00 REVISION 0x04
BIST 0x00 HEADER 0x00 LATENCY 0x00 CACHE 0x00
BASE0 0x00000000d000c004 addr 0x00000000d000c000 MEM 64BIT
MAX_LAT 0x00 MIN_GNT 0x00 INT_PIN 0x01 INT_LINE 0xff
BYTE_0 0x03 BYTE_1 0x00 BYTE_2 0x00 BYTE_3 0x00

You see the INT_LINE 0xff ? THat's the OS's or your BIOS's problem that no Interrupt was assigned.

If you take a look at the Ethernet device:
pci bus 0x0006 cardnum 0x08 function 0x00: vendor 0x10ec device 0x8139
Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+
CardVendor 0x1179 card 0xff31 (Toshiba America Info Systems, Card unknown)
STATUS 0x0290 COMMAND 0x0007
CLASS 0x02 0x00 0x00 REVISION 0x10
BIST 0x00 HEADER 0x00 LATENCY 0x20 CACHE 0x00
BASE0 0x00002001 addr 0x00002000 I/O
BASE1 0xb0102000 addr 0xb0102000 MEM
MAX_LAT 0x40 MIN_GNT 0x20 INT_PIN 0x01 INT_LINE 0x10

You see that INT_LINE 0x10 (= 16 dec) means that the BIOS correctly assinged an interrupt.

This is NOT an OSS problem - it's either FreeBSD or your BIOS. You might want to try an upgrade to FreeBSD-6.0-STABLE to see if that problem goes away.

See post# ... =2488#2488

for instructions to upgrade to -STABLE.

Dev Mazumdar

Return to “BSD”

Who is online

Users browsing this forum: No registered users and 3 guests